Apple TV setup went perfectly

Discussion in 'Apple TV and Home Theater' started by Graig, Dec 18, 2010.

  1. Graig macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #1
    One question though, should I be disabling sleep mode on my iMac when running iTunes Home Sharing and streaming music to my Apple TV? Or does Apple TV handle this?
     
  2. aelalfy macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Berlin, Germany
    #2
    In your iMac display settings well battery settings, you can check the box that says something about wake iMac by other devices on network. So when the iMacs takes a nap, if want your AppleTV to use it, it will auto wake up by the request of your AppleTV.

    Thanks
    AE
     
  3. Graig thread starter macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #3
    Thanks so much for the help, as it turns out this box was checked already. Much appreciated....
     
  4. aelalfy macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Berlin, Germany
    #4
    Np, and yea it's a cool feature, it works well because You don't have to get up to wake your iMac when you want to watch tv.

    Also another thing I found useful, make iTunes open at login, that way when you turn on your computer you just press the power button, and don't have to sit and wait for the comp to launch and click the iTunes icon. Saves about 20-30 seconds of waiting which I found adds up.

    Thanks
    AE
     
  5. Graig thread starter macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #5
    When my iMac went into sleep after about 30 minutes the music stopped and I found that Apple TV had lost the connection to iTunes even though the box was checked.
     
  6. aelalfy macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Berlin, Germany
    #6
    Uncheck the "Put the hard disk to sleep when possible" box. your screen should go to sleep not your hard drive. I don't know if putting the hard disk to sleep when possible should include appletv access. I thought it didnt. Anyways the "wake for network access" box is for when your computer is asleep and you want to use your appletv. Instead of having to go on your comp and turn it back on, accessing the appletv from your couch will make it wake up.

    I'll trying checking the put hard disk to sleep when possible and see if my appletv will lose connection. It shouldn't if im not mistaken.

    Thanks
    AE
     
  7. DeusInvictus7 macrumors 68020

    Joined:
    Aug 13, 2008
    Location:
    Kitchener, Ontario
    #7
    I wish this "wake on demand" feature was available for notebooks. I know it works if there is an external monitor connected, but they should make it so that if the computer goes to sleep but the lid is open, then it should wake when the ATV requests it. Maybe require that the computer be plugged in, but they should add this feature.

    EDIT: Never mind, I just tried my idea and it actually already works. As long as the lid on the notebook is open, ATV can access it and wake it up.

    My new request now is to let the Remote app access over the network when the computer is asleep. I tried to wake it with my iPad, and it didn't show up as a source.
     
  8. Graig thread starter macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #8
    I have unchecked the box for put hard disk to sleep. My computer is set to sleep in 10 min as is the display. It seems that Airport almost always needs to re-connect when awakening the computer from sleep. Is this the same on your computer?
     
  9. aelalfy macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Berlin, Germany
    #9
    I'm pretty sure it is (only if appletv is not using your comp though), the wifi gets shut off as part of the power saving procedure. Regardless though, and I still can't confirm this (because I haven't had the time to try it), your computer should be connected if the appletv is using it. Regardless if the put hard disk to sleep is unchecked or not. The display should go to sleep, but as long as the appletv is using your computer, the computer wifi should not disconnect. I'll try to check the put disk to sleep and make my computer and display sleep time around 10 mins and see what happens while im using my AppleTV.

    I'll update you when I get the chance,

    Thanks
    AE
     
  10. Graig thread starter macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #10
    Thanks again for your input. I played music today for about 2.5 hours before it cut off, yesterday (day 1 as I just hooked it up) it played about an hour berfore quitting. Im going to turn off sleep and try it for a while to see if it cuts out then. When you wake the computer you can see the wi-fi reconnecting and then Apple TV shows the Library again instantly.
     
  11. aelalfy macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Berlin, Germany
    #11
    Ok so you are saying that you played for 2.5 hours before it cut off and the other day it played for an hour?. I'm trying to use common sense before so what I say next is based on ideas not facts. Your computer sleep time is the time your comp would go to sleep in if not "touched" or accessed. Lets say you put that to 10 mins and dont use your computer just your appleTV is your computer goes to sleep in 10 mins and cuts your appletv then you know its that setting. If it takes 2.5 hours, then you know that it cut off for different reason, and would start finding that reason by checking your router settings. Maybe your ip gets renewed daily or something. Also the put hard disk to sleep when possible is based on the time of sleep of your computer, basically once your computer is not touched for "x" minutes the computer sleep and if possible the hard disk too, that what i think this feature means.

    Side note: I'm going to try putting the computer & display (display doesn't matter really) to 10 mins and check the put hard disk to sleep. So for the next 10 mins starting now ill go watch tv on my appletv and wait and see what happens.

    Thanks
    AE
     
  12. Graig thread starter macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #12
    I turned off sleep at 12:15, played music for almost 4 hours without it cutting out so am pretty sure it has to do with sleep mode turning off Airport randomly. I could turn off the automatic sleep and solve the problem but will look further into into router settings. Thanks
     
  13. aelalfy macrumors 6502a

    Joined:
    May 2, 2010
    Location:
    Berlin, Germany
    #13
    Ok you seem to be adding more into the equation. I'm talking about losing connection due to computer sleeping (ie 10 mins) as preset. You telling the comp to auto sleep at 12:15 is not what I'm talking about. That forces the comp to shut down regardless of what its doing at that time specifically and could explain why you could play for 2.5 hours or 1 hour and it cutting off, because in both times when 12:15 hit, the comp slept. Its different from going into the power saving settings and telling the comp to sleep if not touched for 10 mins. The comp in that case would realize that its being "touched" by the appletv and will not shut down in 10 mins.

    So in conclusion, if you have a sleep time set for the computer (ie 12:15) that explains why your comp sleeps, and should have been kind of obvious to you. Setting your computer to sleep in 10, 20 or 30 minutes (even with put disk to sleep box checked) will not interfere with your appletv (ie wont cut it off) from what I experienced.

    Thanks
    AE
     
  14. Graig thread starter macrumors 6502

    Graig

    Joined:
    Aug 23, 2009
    Location:
    Vancouver, BC
    #14
    I'm sorry I guess I didn't explain it quite right. What I meant was that I set sleep to NEVER (It was previously set to sleep in 10 minutes) In other words with this setting the computer would not go to sleep at all.
     

Share This Page