Apple TV Slow to Load iPhoto Videos

Discussion in 'Apple TV and Home Theater' started by webbymac, Sep 30, 2014.

  1. webbymac, Sep 30, 2014
    Last edited: Sep 30, 2014

    webbymac macrumors newbie

    Joined:
    Aug 23, 2009
    #1
    Hi,

    Need a little help here. Just bought an Apple TV(3) so I'm just figuring it all out at the moment.

    Home sharing works as expected, so I can play local, iTunes movies with no great hitch, but videos from within iPhoto take too long to load; the video catches up with the stream and therefore stops! Why is this?

    My Internet speed isn't great at around 5-6mbps so I expect some load times when streaming from the Internet but this issue is from videos on my own mac!

    ATV appears to be connect to my Airport Extreme network at a data rate of 150mb/s according to Airport Utility. Is this not enough? I'm talking about iPhone videos here so yes, they're HD and fairly large file sizes but most of them are only short clips anyway.

    What can I do to improve this?

    Edit: Network info. I have an Airport Extreme upstairs connected to my router. This currently has 6 wireless clients connected to it (various devices, including the atv).

    I have an Airport Express downstairs (in the same room as the atv) which is set to extend the Extreme's network, but only my iPad is connected to that. Not sure why the atv doesn't connect to that.

    Thanks
     
  2. webbymac thread starter macrumors newbie

    Joined:
    Aug 23, 2009
  3. webbymac thread starter macrumors newbie

    Joined:
    Aug 23, 2009
    #3
    Anyone have any thoughts on this at all? My iTunes library is on an external drive and videos and home videos load fine, but my iPhoto library is on the internal drive and videos from there take a while to load through Apple TV.
     

Share This Page