Apple TV stuck at recovery menu

Discussion in 'Apple TV and Home Theater' started by Maxatrillion, Sep 27, 2009.

  1. Maxatrillion macrumors newbie

    Sep 27, 2009
    I have an Apple TV with XBMC and Boxee on it, and I just restarted (by holding down "-" and "menu") it today because it was acting a little jumpy. Now it is stuck at the Apple TV Recovery menu. If I try to push restart the screen goes black and comes straight back to the same menu. If I push Run Diagnostics it says that my apple tv is working fine. And when I try to do a factory restore It goes to an apple symbol with a status bar, restarts and goes back to the same menu. If anyone has any solution it would be great.
  2. Maxatrillion thread starter macrumors newbie

    Sep 27, 2009
    Cancel that I got it working again. Just unplugged and reused the patchstick.
  3. rogervzv macrumors member


    Aug 18, 2009
    Huntington Beach, CA
    What is a patchstick?
  4. kitesurfer72 macrumors newbie

    Mar 14, 2010
    Update downloads but Install Fails

    How did you fix it?

    I have been trying over and over again to update my apple tv to the latest version (3.0.2) of the software. It downloads the update just fine and then I select update now. It shows the apple logo and begins the update, progress bar shows movement until 3/4 of complete then I get the awesome, very descriptive answer "Your apple TV cannot be updated". Earth shattering, the apple TV programmer should have just written "If you don't own a protection plan we just found a new way to charge you because you are going to have to call us to fix this now sleek looking box in front of your TV" or "I am too busy to give you a proper error code" or "The sky is Blue" or "PEBKAC Error (Problem Exist Between Keyboard And Chair)" at least I would have laughed.

    Back to the issue:
    So after the GREAT ERROR MESSAGE the Apple TV takes me to the Apple TV recovery menu and 3 options, 1. Restart Apple TV (does nothing except loop back to the recovery menu), 2. Run Diagnostics, 2. Factory Restore. I have tried all 3 options, diagnostics says its running correctly (every time). However now that I've done a factory restore I went from being stuck on 3.0.1 (which WORKED!!) to 1.1.

    Any suggestions on how to get the upgrade and install to work?

Share This Page