Apple TV Update: Where has Netflix "Recently Watched" gone?!

Discussion in 'Apple TV and Home Theater' started by Gamoe, Jan 31, 2013.

  1. Gamoe, Jan 31, 2013
    Last edited: Jan 31, 2013

    Gamoe macrumors regular

    Sep 19, 2006
    I recently updated to the latest Apple TV software. Now, I can't find "Recently Watched" in the Netflix app. Has this just gone with the update? It makes Netflix on the Apple TV a lot less usable now.

    EDIT: Nevermind, it's suddenly back...
  2. Plutonius macrumors 604


    Feb 22, 2003
    New Hampshire, USA
    It also very occasionally disappears on my Roku. Powering it off then on fixes the problem.
  3. Pyromonkey83 macrumors 6502

    May 24, 2009
    This. It will also disappear from my Samsung Smart TV app sometimes as well.. Its a bit annoying but normally re-launching the app will fix it, or if not then turning the TV off then back on will.

    Annoying Netflix bugs...
  4. warvanov macrumors 6502a

    Oct 13, 2011
    I've experienced this problem occasionally also. It's a problem with Netflix not delivering the recently watched data to your device. From my experience, it's a problem with the Netflix servers, not with your device. (I've experienced the same problem simultaneously on multiple devices only to have it fixed within hours.)
  5. andyfu macrumors newbie

    Nov 19, 2012
    Just be patient

    I lost "Recently Watched" after updating the software on my Apple TV. I called Netflix, but they were unable to help. They did not know if this was a glitch or a feature of the update. I tried completely restoring the Apple TV (including another download of the software) but that did not fix the problem. So I gave up and went to bed. The next morning when the Apple TV was turned on "Recently Watched" had returned. So given my experience and the comments above the best course of action seems to be no action, but rather patience, which is not the answer you usually want when your device is not functioning properly.
  6. Mac Fly (film) macrumors 65816

    Mac Fly (film)

    Feb 12, 2006
    I agree it's an issue with the Netflix remote servers. I've had this issue come and go a few times over the past 2 years, but tonight I tried the restart your device trick - in my case Apple TV - to no avail.

    The solution to this issue is to wait it out. It's usually fixed in a few hours. Go take a break: read a book or talk to a random hot girl on the street.
  7. Rushli0n macrumors regular

    Aug 27, 2012
    Netflix on my ATV3 has been really flaky lately. We are getting "Netflix is down" message quite a bit. Only thing that fixes is a Restart of the machine. Oddly enough, this doesn't appear to be happening on my ATV2.
  8. Garsun macrumors regular


    Oct 20, 2009
    Well, it's been missing about a week so far for me and it still has not returned.
    Do not know if it has something to do with the new profiles or not.
    I somehow now have two profiles, one is mine and one came out of no where.
  9. twintin macrumors 6502

    Aug 10, 2012
    No such issues here with latest update on my ATV. But I'm in Sweden on the other hand (if that makes any difference).
  10. Garsun macrumors regular


    Oct 20, 2009
    It magically reappeared with no action on my part. It was missing this afternoon and tonight it's back. I guess complaining on MacRumors was the cure:cool:

Share This Page

9 January 31, 2013