Apple TV won't see my desktop PC anymore

Discussion in 'Apple TV and Home Theater' started by pilot1226, Jun 1, 2014.

  1. pilot1226 macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #1
    Hiya,

    Having a bunch of problems over the last few months and I'm out of ideas on troubleshooting. Hopefully I overlooked something simple.

    I have the AppleTV 2 with the latest Software Update connected to my TV via HDMI in my living room, upstairs.

    My internet is Verizon FiOS, and I've disabled the wireless portion of the gateway that they provide you in favor of my Linksys E3000 router which also has been updated to the latest stable firmware.

    Connected to the E3000 is my Desktop computer in my basement via wireless connection, as well as the AppleTV itself. Here's where it gets tricky.

    The AppleTV itself has an internet connection: I'm able to stream movies and shows using the native apps. The computer also has an active internet connection. They both work fine separately.

    I can mirror from my iPad 3 and my iPhone 5S to the AppleTV without any problems.

    Previously, I was able to access my computer through the AppleTV menu and play digital video and audio files. Now, when I click over to the "Computers" section of the AppleTV menu, a screen comes up telling me that Computers I've enabled will appear here.

    Here's what I've done in the meantime:
    1. I've reset the AppleTV and restarted from scratch.
    2. Verified the Home Sharing username, password, etc. settings are enabled in iTunes, and iTunes is open.
    3. I've reset the E3000 router and restarted from scratch.
    4. Temporarily disabled the WPA2 encryption on my router, tried WEP and Open networks. No luck.
    5. Have set a static IP address for the computer and set it into a DMZ thinking it was a firewall issue.
    6. Suspended MS Security Essentials (the only AV program I use on my PC)
    7. Have tried using the Verizon gateway's wireless for a connection.

    Still no good. Anything else I may be overlooking? Maybe a process or two in Windows that I need to have running in order to get the two devices talking to each other.

    Thanks,
    Pilot
     
  2. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #2
    Which of your network equipment is giving out the addresses? the linksys or fios?

    this might help http://www.dslreports.com/faq/verizonfios/3.0_Networking#12506
     
  3. Panch0 macrumors 6502a

    Joined:
    Feb 23, 2010
    Location:
    Virginia
    #3
    Are you able to see the iTunes Library on the PC from the Music app in iPhone/iPad?

    Have you confirmed that all devices are connecting to the same Wireless Network (SSID)? Have you checked the the IP Address and Subnet Mask of all devices?

    These are the ports used for home sharing:
    TCP ports 123 and 3689 as well as UDP ports 123 and 5353

    per this support page:http://support.apple.com/kb/TS2972?viewlocale=en_US
     
  4. pilot1226 thread starter macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #4
    The DHCP is handled by the Linksys router. The Linksys is connected to the Verizon Gateway via ethernet.

    Yeah, at first I thought a guest network or something as well. I made a temporary change to my SSID to double check that and they're both on the same one. I know my E3000 broadcasts both 2.4 and 5 GHz bands, so this was my first hunch. I also temporarily disabled the 2.4 band, and then did the same with the 5 band, to make sure they weren't causing the screwup.

    I figured that there might have been a need for Port Forwarding, so I set my desktop PC in a DMZ with a static IP address. Maybe I need this for the AppleTV too. I'll double check the settings when I get home later and Static & PF the AppleTV.

    The thing that gets me is that it WORKED for months and months. And it still works for everything excluding the home sharing.

    Thanks for the advice, fingers crossed.
     
  5. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #5
    Take the linksys out of the equation and just use the fios router (reset it back to factory)

    If you have no issues then you know it's the linksys. I have seen a lot of connection issues with linksys. So much that I cringe whenever I walk into a clients business and see they are using one.
     
  6. BuddyRich macrumors member

    Joined:
    Mar 21, 2012
    #6
    A few common tweaks you can try on your windows box running itunes:

    Do all of these with itunes closed:

    First - uncheck ipv6 protocol support in the network adapter on the PC running itunes.

    Second - "Repair" the bonjour program from add/remove programs.

    Download this utility and run it on the PC running itunes.

    http://hobbyistsoftware.com/bonjourbrowser

    You'll see a window with a list of bonjor services...

    of importance, you want to see a line with:

    _home-sharing._tcp.(UserName's Library).

    If you don't see that, then homesharing isn't being exposed by bonjour to its mesh network. If you do, highlight the service and check the details to see what ips its using and make sure both are on the same local network and subnet.
     
  7. pilot1226, Jun 4, 2014
    Last edited: Jun 4, 2014

    pilot1226 thread starter macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #7
    Ok, I don't see that line in the browser. Here's what I do see:

    [​IMG]

    Edit: I've also tried the step above by connecting directly to the Verizon gateway, with the same result. I think the problem is now pointing to the computer itself. Something must have been deleted or removed.

    Yesterday I uninstalled and reinstalled iTunes again.

    I checked my services.msc and it shows that Bonjour is Automatic Start and currently running.

    Still no luck.
     
  8. pilot1226 thread starter macrumors 6502a

    pilot1226

    Joined:
    Mar 18, 2010
    Location:
    USA
    #8
    I got it!

    I spent an hour or two trolling some Google results about the issue and found these two clues:

    1. The Linksys E3000 potentially doesn't play nicely between the computer and the ATV if you're running in WPA2 "Mixed Mode"

    2. IPv6 should be unchecked if you're using Win7x64 in the wireless adapter properties.

    I did both of these changes (running WPA2 Personal now) even though I'd previously tried disabling and using WPA and WEP during my troubleshooting.

    I restarted the computer after changing the IPv6 option I listed above and ran Bonjour Browser. I see the entries you're talking about, so I went upstairs to check my iTunes and sure enough it's on and working.

    All set! Thanks for the help and suggestions. Seems like it's a Windows 7x64 glitch.
     
  9. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #9
    Glad it worked our
     

Share This Page