Apple TV won't sync entire Music Library.....

Discussion in 'Apple TV and Home Theater' started by d.f, Sep 24, 2007.

  1. d.f macrumors regular

    Joined:
    Jan 11, 2003
    #1
    anyboy help with this?

    i selected sync music and un checked all other categories (Movies, TV shows, etc). The first time i left it overnight synicng via ethernet cable. in the morning it had finished, but i noticed only 3,500 songs (80Gb/lossless) of the entire library of 10,000 (203Gb/lossless) had been synced.

    i knew that i wasn't going to get all my music on the ATV as the internal HD is only 160Gb, but shouldn't it be snycing a lot more than a third of the library?

    streaming works fine with entire library. just wanted to fill the HD with music so i didn't have to have iTunes running to listen to tunes.

    i'd appreciate any tips on what i might be doing wrong.
     
  2. MikieMikie macrumors 6502a

    Joined:
    Aug 7, 2007
    Location:
    Newton, MA
    #2
    Yes, you did nothing wrong.

    IF your :apple:TV is not syncing TV, Videos, Podcasts, images from iPhoto, etc., then it should have filled itself up to the top with muzik.

    Since it did not, and since you have indeed checked that you didn't mistakenly sync some of the above-excluded content, I have the "fix
    all" that works in a lot of cases:
    1. Shut down your computer.
    2. Unplug your :apple:TV.
    3. Shut off your router.
    Have a drink, then
    1. Turn on your router.
    2. Turn on your :apple:TV
    3. Turn on your computer.

    At the very worst, you've enjoyed a drink. But seriously, iTunes will, on restarting after all of the shutting down and turning back on, finish its sync. If not, let us know.

    -- Mikie
     
  3. d.f thread starter macrumors regular

    Joined:
    Jan 11, 2003
    #3
    no joy

    thanks for the tips

    sadly it did not work. i have noticed a warning triangle next to the Apple TV icon in the iTunes sources list. It says 'coulnt not sync song 'xxxx' asit could not be found'..... there's over 100 in the drop down list.

    odd, as if i go to play any of the songs manually through iTunes is plays perfectly without any 'seeking' delay.

    not sure how to get iTunes to re-scan it's own library, to hope it fixes itself this way.... any idea??
     
  4. easy4lif macrumors regular

    easy4lif

    Joined:
    Mar 31, 2005
    Location:
    Southbay CA
    #4
    make sure all your music is check marked. I had a problem recently where the music wouldn't show up on the Apple TV and found out that you have to have all the music checked marked. to do it simply:

    select all the music on itunes, right click, and select "check selection"
     

Share This Page