Apple TV wont update to latest firmware

Discussion in 'Apple TV and Home Theater' started by foiden, Sep 29, 2012.

  1. foiden macrumors 6502a

    Joined:
    Dec 13, 2008
    #1
    I have the latest generation Apple TV and I was able to upgrade fine up until software version 5.0.2. However, for this latest update, it would finish downloading the latest software package, but right after it gets past the download phase, just as the installation is about to start, it immediately stops with a message saying "Software update is not successful." I tried resetting it. Unplugging it and restarting it. I even attempted the factory restore function, and I still get the same result.

    Fortunately, I can still use my Apple TV, but I'm still stuck with 5.0.2. Anybody else have this issue and know how to resolve this? Seems to have no problem with connecting to download, but it's the followup that stops it each time.
     
  2. blevins321 macrumors 68030

    Joined:
    Dec 24, 2010
    Location:
    Winnipeg, MB
    #2
    Something might have gotten corrupted. Do you have a micro USB cable handy? Like from an android phone or kindle? You can plug the ATV into your computer and do a hard restore with iTunes.
     
  3. foiden, Sep 29, 2012
    Last edited: Sep 29, 2012

    foiden thread starter macrumors 6502a

    Joined:
    Dec 13, 2008
    #3
    Hmm. I guess I'll have to get one of those cables, then.

    Edit: Nevermind. I actually do have one of those cables. An unusual one, indeed. Oddly enough, it went to one of those Blue tooth ear pieces that didn't use the typical connector that my other Blue Tooth earpiece (and several other devices) used. Didn't realize it was a micro USB standard as I don't have any other small connector-to-USB that used that shape.
     
  4. foiden thread starter macrumors 6502a

    Joined:
    Dec 13, 2008
    #4
    Ok. Now I have another problem. I plugged in the micro-USB cable for the ATV3. I also have a Micro-B type as what people said works.

    The Apple TV correctly goes into the mode where it would show to connect it to iTunes. Problem is, that it doesn't show up as a device in iTunes. I'm following the instructions where I disconnect all cables. I connect the Micro USB first to the unit and then to the usb port of the computer. I then plug it back in.

    The device doesn't show up to even do a restore.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Are you connecting the power cable AFTER connecting the USB?

    See this.
     
  6. foiden, Sep 30, 2012
    Last edited: Sep 30, 2012

    foiden thread starter macrumors 6502a

    Joined:
    Dec 13, 2008
    #6

    Yes I am.

    Edit:

    Found the issue. It was the cable itself. Must've been a defective one that only really carries power. (It was used for a bluetooth Headset which only used it for power charging).

    Upon obtaining a different micro-usb cable, it worked. Apple TV is now running with the latest.
     

Share This Page