Apple TV

Discussion in 'Apple TV and Home Theater' started by butterwm, Jul 11, 2012.

  1. butterwm macrumors member

    Jun 25, 2012
    I have two Apple TV units I bought. Setup went good on both except for I am unable to get home sharing working. It comes up with an error message on both devices that "Apple TV can't connect to the server at this time. Please try again later." Both ATV's have the latest software update and I have restarted them both along with trying a second iTunes account and password. I restarted my router (Time Capsule 2GB) and there are no PC's in the mix, it's all Apple products so it should work well together. Everything else works fine as far as renting movies and airplay, it's just the home sharing.

    Anything I am doing wrong or any suggestions?
  2. mcnallym macrumors 6502a

    Oct 28, 2008
    Home sharing is not enabled by default in iTunes. You haven't stated that enabled this in whatever your iTunes is running on locally.
  3. butterwm thread starter macrumors member

    Jun 25, 2012
    Sorry, forgot to mention. Yes, I have enabled home sharing in my iTunes which is on the home network. I even went and enabled the sharing on both the iMac and MacBook Air and I can transfer stuff from my library between those two computers so I know that it's working.
  4. heisenberg123 macrumors 603


    Oct 31, 2010
    Hamilton, Ontario
    is your iTunes library stored on that time capsule? if it is test to make sure you can play it on one of the macs just to rule out its not having an issue playing things in your library
  5. butterwm thread starter macrumors member

    Jun 25, 2012
    It's not, I am just using the time capsule for backup only. I have the iTunes account on both my iMac and MacBook Air. I made sure they were on and that iTunes was open on that computer and home sharing is enabled.
  6. MarkG21 macrumors regular

    Mar 21, 2010
    In iTunes, can you see your other computer's library?
  7. Eddafl macrumors newbie

    May 7, 2012
    Lol i had the exact same problem earlier sorted it out by entering my account details under "test network" in the network setiings, hope it works for you.
  8. butterwm thread starter macrumors member

    Jun 25, 2012
    It's funny, I just tried it again and it worked. Something must have been down on their end.

Share This Page