Apple TV4 - Error 0033: Customer not authorized for content requested

Discussion in 'Apple TV Apps' started by Bkrebsbach, Mar 23, 2016.

  1. Bkrebsbach macrumors newbie

    Joined:
    Mar 23, 2016
    #1
    Please HELP!!!

    I have been watching live TV and recent episodes of my favorite shows on a lot of different apps (WatchESPN, WatchABC, CNN GO, Comedy Central) on my 4th generation Apple TV for a couple months now. I have been logged in using my parents DirectTV username and password and haven't experienced any problems but now I am seeing the "Error 0033: Customer not authorized for content requested" for most of the apps I use regularly. It seems weird that when I sign out and back in to all of the apps it no longer asks for the cable provider username and password like it did when I first accessed them. I have verified that my parents haven't changed anything about their cable services.

    I have tried:
    • Resetting and unplugging Apple TV.
    • Deleted and re-downloaded all the apps.
    • Signed out and back into to all the apps.
    • Tried using Internet Explorer, FireFox, Google Chrome and deleted cookies on all.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Did you check with your parents that they are still have Direct TV?
     
  3. gkarris macrumors 604

    gkarris

    Joined:
    Dec 31, 2004
    Location:
    "No escape from Reality..."
    #3
    Did they change their subscription so that the TV apps you are trying to use are no longer in their package?
     
  4. Carlanga macrumors 604

    Carlanga

    Joined:
    Nov 5, 2009
    #4
    Sounds like a package change or some trial that is now over for channels for parents don't have.
     
  5. jbrooksga macrumors newbie

    Joined:
    Oct 23, 2008
    #5
    I'm having the exact same problem now. I know that none of the channel subs have changed. Did anyone find a resolution to this?
     
  6. Bkrebsbach thread starter macrumors newbie

    Joined:
    Mar 23, 2016
    #6
    --- Post Merged, Aug 26, 2016 ---
    Has nothing to do with a change in package. It has something to do with trying to login while I'm logged into my wifi. It will only let me log in if I disconnect from wifi on my phone then log in while I'm connected to LTE.
     
  7. jbrooksga macrumors newbie

    Joined:
    Oct 23, 2008
    #7

    Wow that actually worked.

    They must be blacklisting IP addresses. Really bizarre.
     
  8. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #8
    Do you live in a totally different state than your parents?
     
  9. barkal923, Oct 18, 2016
    Last edited: Oct 18, 2016

    barkal923 macrumors newbie

    Joined:
    Oct 18, 2016
    #9
    This worked for me after having tried every suggestion I could find on the internet. And yes, I think Directv is blocking IP addresses. Why? I had two Directv accounts in different cities. I cancelled one. I was not able to verify AppleTV channel apps from the site where Directv had been cancelled.
     
  10. bunkybear macrumors newbie

    bunkybear

    Joined:
    Jul 19, 2017
    #10

    I agree it's Direct TV problem. I used to have two accounts with Direct TV and cancelled one. When I sign into my computer it still has an account with Direct tv. Plus I do believe they are blocking Third party apps and ip addresses from Apple TV apps and Iphone apps as well. Says I dont have subscription to the networks i am accessing.
     

Share This Page