Apple USB SuperDrive is not supported on this Mac

Discussion in 'OS X Yosemite (10.10)' started by keysofanxiety, Apr 27, 2015.

  1. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #1
    Hi MacRumours,

    Hope you're all keeping well. The optical drive in my friend's 2011 17" MacBook Pro failed (unsurprisingly), and we're trying to get BootCamp sorted. When attempting to mount the Windows ISO through Disk Utility to an external HDD, it kicked up loads of error -254 problems and the like, and also kicked up the same error on my MacBook. Disk Utility just doesn't seem to work like it used to. :(

    So I figured might as well use the Apple USB ODD to install, right?

    How wrong I was. When plugging it in, it surprisingly says that it's not supported on this Mac. I'll take you through what I've done so far.

    1) Deleted existing optical drive through some kext or something, restarted computer.
    2) Ran the sudo nvram boot-args="mbasd=1" command through Terminal, restarted, still no luck.
    3) Also added "mbasd=1" to the Kernel Flags in com.apple.Boot.plist. Saved the changes, restarted, still no luck. Brought up the editor to that plist file and the changes had definitely saved.

    Not only that, but now when I shut down or restart the Mac, it comes up with a black screen and a cursor. Won't go beyond that and have to force shutdown. It's a recent reimage after fitting an SSD. I've definitely messed up something really badly and I'm getting really frustrated with this. I wish Apple made it easier , sick of the useless software limitations they apply.

    Is there anything additional you can suggest to make the SuperDrive work? And possibly any suggestions RE: black screen on shutdown?

    Thanks for any advice you can offer!
     
  2. keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    UPDATE: So, we're getting closer. I used a Samsung external USB DVD drive which mercifully works as a USB ODD should - as in, reads a DVD. Partitioned the disk through Boot Camp Assistant. Restarted, and now there's a flashing underscore when booting into the Windows installation DVD. Tried 3 different DVDs: Windows 7, Windows 8, and Windows 8.1. All the same issue.

    Apparently the flashing underscore is something to do with Macs using EFI rather than a BIOS. It's really one step forward, two steps back. I can't ever remember BootCamp being this difficult to set up ...

    Any advice as ever would be hugely appreciated :)
     
  3. Eithanius macrumors 65816

    Joined:
    Nov 19, 2005
    #3
    Is your Samsung external DVD drive bus-powered...?

    The Apple USB SuperDrive is designed for Macs without the internal optical drive. If I'm not mistaken, these Macs have a rather higher powered USB ports to drive the external SuperDrive. Not sure if the under-powered USB on your Mac contributes to your hanged Windows disc booting.
     
  4. keysofanxiety, Apr 27, 2015
    Last edited: Apr 27, 2015

    keysofanxiety thread starter macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Hi Eithanius, I really appreciate your response - I hadn't thought of this.

    Yeah it's powered through the USB port. I've gone a different way and I'm mounting the Windows installer to a USB through my Windows PC from http://wudt.codeplex.com/, to do the job that Disk Utility kept failing at. So hopefully that'll work ...

    UPDATE: USB pen not even detected on boot, holding 'Alt' only brings up Macintosh HD. Tried all 3 USB ports. USB drive comes up in OS X. It must be bootable but obviously not if EFI doesn't display it. I think I'll give up for now and maybe review it this evening.
     
  5. loekf macrumors 6502

    loekf

    Joined:
    Mar 23, 2015
    Location:
    Nijmegen, The Netherlands
    #5
    Did you try a USB Y-cable ? Y-cable has two USB connectors for more power.
     
  6. Antoni Nygaard macrumors 6502a

    Antoni Nygaard

    Joined:
    Jun 23, 2009
    Location:
    Denmark
    #6
    If i remember correctly it's not possible to install Windows on a mac that has a built in DVD drive with USB or external DVD drive. it has to be the Internal DVD drive.
     

Share This Page