Apple Watch 4 not recognized on iPhone SE

Discussion in 'Apple Watch' started by edhchoe, Sep 30, 2018.

  1. edhchoe macrumors 6502a

    edhchoe

    Joined:
    Oct 28, 2011
    #1
    My apple watch 4 has been paired with my iPhone SE and the watch works OK.
    But I cannot install a whole bunch of Apps on the watch.
    And the watch doesn't show up as "Apple Watch 4" on my watch app.
    Also, the new faces - infograph and info modular - do not show up on the face gallary.

    Is anybody else experiencing this problem?

    I have notified Apple about my problem through Feedback app.
     

    Attached Files:

  2. Mercenary macrumors 65816

    Mercenary

    Joined:
    Sep 17, 2012
    #2
    From Apple website https://support.apple.com/en-gb/HT204505

    Before you begin
    To set up and use your new Apple Watch, you need an iPhone with the latest version of iOS.

    • Apple Watch Series 3 (GPS + Cellular) or later is compatible with iPhone 6 or later
    • Apple Watch Series 3 (GPS) or earlier is compatible with iPhone 5s or later
     
  3. dcpmark macrumors 6502a

    Joined:
    Oct 20, 2009
    #3
    My S4 works perfectly with my SE, so whatever your issues are they have nothing to do with the model of your iPhone.

    Did you back up from a previous watch? I did, and the new faces were not dispayed until I edited the watch faces and added them. Also, I couldn’t install a few 3rd party apps initially until the app makers updated their apps.

    Lastly, try restarting your phone and watch.
     
  4. edhchoe thread starter macrumors 6502a

    edhchoe

    Joined:
    Oct 28, 2011
    #4
    I tried restoring from back up when pairing, and I tried pairing as new watch also.
    I restarted both devices numerous times.
    The new faces still do not show up.
    I can't get any 3rd party apps to install.

    But your SE is fine.
    Therefore, something is wrong with my SE or my watch.
    What iOS versions do you have?
     

    Attached Files:

  5. dcpmark macrumors 6502a

    Joined:
    Oct 20, 2009
    #5
    iOS 12 on the SE, Watch 5.0.1 on the watch, although it worked perfectly with 5.0.
     

Share This Page

4 September 30, 2018