Apple Watch does not sync SMS?

Discussion in 'Apple Watch' started by plastus, Jun 9, 2015.

  1. plastus macrumors newbie

    Joined:
    Jun 19, 2009
    #1
    Does anyone know if this is how the Apple Watch is supposed to function? It only syncs iMessages, but not SMS threads.
     
  2. Scaleo macrumors member

    Joined:
    Nov 17, 2013
    Location:
    Munich, Germany
    #2
    I had this issue too.
    I then enable SMS forwarding on the iPhone for my MacBook Pro. After I did this my Watch received SMS. I don't know why this works.
     
  3. plastus thread starter macrumors newbie

    Joined:
    Jun 19, 2009
    #3
    Thanks. I will give it a try when I get back home. I disabled SMS relay for my iPad, so I'm hoping once I re-enable it it'll kick start the Watch to start syncing as well.
     
  4. midloman macrumors regular

    midloman

    Joined:
    Feb 10, 2010
    Location:
    Midllothian, VA
    #4
    I have an older Macbook Pro and an iPad. On my iPhone, under Settings --> Messages, I have only one entry for Text Message Forwarding. It says 1 device, and it's my iPad.

    How do I add the Macbook Pro? Does that have to be added as well to get the texts on my watch? I think I had the same problem earlier today; the iMessages work fine but I'm not sure about the SMS. I think I got one earlier and it didn't come through.
     
  5. plastus thread starter macrumors newbie

    Joined:
    Jun 19, 2009
    #5
    Update: Didn't work. I'm on WatchOS 2.0 Beta 1 so maybe it's due to that. When a text message comes through, I only get the notification. No option to reply like with an incoming iMessage. If anyone has other suggestions, please post! Thanks!
     
  6. Wrightpd macrumors newbie

    Joined:
    Jun 16, 2012
    Location:
    UK
    #6
    I have the same issue on WatchOS2 beta1, i get notification of an SMS on the watch but the do not appear in the messages app.

    Also if i try and send a new message to someonee via SMS (as they don't have an idevice) it try to send it as a iMessage then fails
     
  7. davethorp macrumors regular

    Joined:
    Jan 28, 2010
    Location:
    Preston, Lancashire, UK
    #7
    Exactly the same here on OS2b1. Probably one of many bugs in that version
     

Share This Page