Apple Watch/iPhone sending iMessages using my email...

Discussion in 'Apple Watch' started by Maddux4163, May 8, 2015.

  1. Maddux4163 macrumors member

    Joined:
    Apr 22, 2015
    #1
    So my watch and phone seem to randomly send iMessages through my email and not my phone number. Why is that? I prefer it to send using my phone number
     
  2. themikea macrumors regular

    themikea

    Joined:
    Aug 15, 2014
    Location:
    Toronto, ON
    #2
    My girlfriends watch was doing this also, even though the send-from address was the phone number. I ended up having multiple iMessage conversations going with her. She ended up removing her iCloud email from iMessage on the iPhone. She doesn't use that email for messages anyway.

    Couldn't find a way to change it specifically from the watch or the watch app itself.
     
  3. Maddux4163 thread starter macrumors member

    Joined:
    Apr 22, 2015
    #3

    How do I remove it?
     
  4. themikea macrumors regular

    themikea

    Joined:
    Aug 15, 2014
    Location:
    Toronto, ON
    #4
    On the iPhone:
    Settings > Messages > Send & Receive

    Make sure your phone number is checked under "Start new conversations from" and uncheck your email from "you can be reached by message at".
     
  5. editingsofa macrumors newbie

    Joined:
    May 7, 2015
    #5
    Go into settings> messages> Send & receive> uncheck your email
     
  6. Maddux4163 thread starter macrumors member

    Joined:
    Apr 22, 2015

Share This Page