Apple Watch not showing calendar events

MDePew24

macrumors regular
Original poster
Jun 23, 2008
189
74
Ballwin, MO
Since I updated to the latest OS's (iPhone 11 Pro and Series 4 watch) I am not seeing any of my calendar events on my watch complication. Always says No more events yet my calendar on my phone has events. I have the calendar set to mirror my phone too.

Anyone have any suggestions? I have tried Apple Watch App (on phone) -> General -> Reset -> Reset Sync Data but that didn't do the trick.

Any help would be appreciated.
 

dman999

macrumors newbie
Jun 24, 2010
18
1
Known issue with Device mgmt/ MDM (in my case MobileIron), and super frustrating for me too.

This thread details others seeing it as well. https://discussions.apple.com/thread/250651655

Current workaround - going into Settings -> Passwords & Accounts -> turning your calendars off and back on in all accounts. Let it re-download calendar items to phone, and you should be back in business.
 
  • Like
Reactions: MDePew24

Targets R Us

macrumors member
Jan 13, 2012
36
32
I'm having the same issue. Tried the above, no joy. Did a reset of all data, no joy. Did a re-pair, also no joy. Really frustrated at this point.

-Jeff
 

Miimac7

macrumors newbie
Nov 15, 2019
2
0
I have had an issue with my calendar not syncing to my series 5 Hermes Apple Watch pretty much since sept 2019. I have spent 40+ hours on the phone and in store with Apple and no one can figure out why my calendar (which is shared with my husband) will sync to multiple devices and not my watch. I have literally tried everything short of buying a new watch. All software is updated and current as of this post (watch 6.1.2 and iOS 13.3.1) and the issue remains.

Here is what is happening:
my one shared Apple calendar (both users have an iCloud calendar) shows up. Then one random day the events are no longer there. They are on my phone 2 iPads and computer but not the watch. So to get the events back I need to: un-pair/re-pair; on/off; or hard reset. I list all these options because I’ve done them all and sometimes I need to try mutiple actions to get the events back. For example I turn on/off and events do not come back so then I may choose to hard reset or un-pair/re-pair to get the events back.

Anyone have this issue??

Apple tech has of course stoped responding to my inquiries as to what the “engineers” have found. Logs and hardware diagnostics have been run on my watch and phone and the engineers are supposed to be looking into these to see if they see a corrupt file or issue. I have not heard anything for 3 weeks and the tech is not responding.

Thinking of buying a new watch and seeing if this solves the issue.

thoughts??