Apple WatchOS 4.2 Radio App issues

applesandarrows

macrumors newbie
Original poster
Oct 31, 2017
2
0
I installed 4.2 last night and everything seems to be working normally. However, when I try to use the Radio app on cellular I keep getting the message that says I need to connect to cellular or WiFi but I'm on cellular. I've tried restarting the watch and toggling the cellular on and off but that did nothing. Then when I came back in the house and my watch connected to the iPhone the radio app started working again. Has anyone else experienced this issue? If so, do you have any trouble shooting suggestions? I've tried rebooting the watch and toggling cellular on and off with no success. I'm hoping to not have to send the watch back in.
 

chrismac2

macrumors regular
Jan 14, 2008
168
152
Seattle, WA
I am experiencing the exact same issue......so you're not alone. I'm not sure if Radio app was working properly on 4.1 because I just never tested it. Today, after updating to 4.2 last night, was the first time I tested the Radio app by turning off my iPhone and turning off wi-fi on the watch. I have LTE and am able to place phone calls with the watch just fine. But Radio app reports no internet connectivity.
 

chrismac2

macrumors regular
Jan 14, 2008
168
152
Seattle, WA
It's not listed in the Release notes for 4.2 b1, but I'm hoping it just a 4.2 beta issue and will be resolved in an upcoming beta. Too bad I didn't test it on official 4.1 release before updating to the next beta
 

warburg

macrumors 6502a
Jul 27, 2008
708
153
How long should it take to update to 4.1? My watch has been "Verifying" for 2 hours.