Apple will start to pull apps that are not 3.1 compatible (with screen shots)

Discussion in 'iPhone' started by HiFiGuy528, Sep 20, 2009.

  1. HiFiGuy528 macrumors 68000

    HiFiGuy528

    Joined:
    Jul 24, 2008
    #1
    I received word from a developer who was forced to change his app to 3.1 only that Apple will start pulling non 3.1 compatible apps off the AppStore. This means that those of us who aren't upgrading due to tethering hacks or JB on 3gs phones will have to upgrade if we want new or updates to our apps. This really sucks. Update with screen shots. These are the newest apps on the AppStore.
     

    Attached Files:

  2. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #2
    If this is true this is douchbaggery at it's finest. However, I've learned to never believe anything anyone says without official word from Apple. Since there is an NDA I would venture we won't hear too much from developers (sadly). There are far too many 'friends of friends' around here.
     
  3. YoungLew macrumors regular

    Joined:
    Jun 8, 2009
    #3
    To be honest that makes perfect sense, as from Apples prospective they want you to have the latest firmware........

    So why would they want software in their App store which isn't capable of supporting their lastest firmware that everyone is running (i say everyone as i'm sure in the eyes of Apple JB'ers aren't acknowledged)
     
  4. Lakerfan210 macrumors regular

    Joined:
    Jun 14, 2009
    #4
    That sucks. Well even more reason for me NOT TO upgrade to 3.1 since I hardly ever get apps from there.
     
  5. Baccarat macrumors newbie

    Joined:
    Aug 24, 2009
    Location:
    Houston, Texas, USA
    #5
    My guess is that Apple will pull apps that are incompatible with 3.1, but they will not force apps to be marked as 3.1 only. This is exactly the same thing that happened shortly after 3.0 came out, but there are still plenty of apps that are still 2.x compatible.

    Here is an article from back when 3.0 was being released.
    http://www.geek.com/articles/apple/iphone-apps-must-be-os-30-compatible-now-2009058/
     
  6. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #6
    How is this incentive to not upgrade? I get that you don't buy apps there and such, but say you do one day ... you'll be forced to upgrade eventually.
     
  7. mikes63737 macrumors 65816

    Joined:
    Jul 26, 2005
    #7
    Why can't Apple just have the App Store hide apps that are not compatible with your iPhone software version, or maybe even grey out the buy button and put a little note explaining that the user needs to update their software?

    Not only is this unfair to developers, but consider people who have dialup on their PC at home, can't download a 200+ MB file, and use the App store on WiFi at work or a public hotspot. It's not fair to lots of people.
     
  8. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #8
    It's what most Apple customers expect. They upgrade to the latest firmware religiously and expect all applications to be fully compatible. It makes sense for Apple and their customers. Their is no way Apple should allow incompatible applications to stay in their store.

    Accept it. They are not going to cater to hackers and jailbreakers to the detriment of the majority. :cool:
     
  9. HiFiGuy528 thread starter macrumors 68000

    HiFiGuy528

    Joined:
    Jul 24, 2008
    #9
    What the developer told me was "Apple will not approve his app if the app supports 3.0". His app is now 3.1 only. Buyers can not buy the app unless the iphone is on 3.1.
     
  10. Givmeabrek macrumors 68030

    Givmeabrek

    Joined:
    Apr 20, 2009
    Location:
    NY
    #10
    Wow that's an interesting twist! A little hard to believe. Seems like it would cause too many problems if it only works with one version of firmware. You can't expect the whole world to upgrade at the same time. :(
     
  11. SIUGRAD99 macrumors regular

    Joined:
    Jan 20, 2008
    #11
    All those who choose to defy Apple and Jailbreak your phones have no room to complain. Apple sets the rules for their device and if you don't like it then go find another phone. I am fed up reading about how people who refuse to follow the rules should somehow have their thoughts considered when Apple makes decisions.
     
  12. firewood macrumors 604

    Joined:
    Jul 29, 2003
    Location:
    Silicon Valley
    #12
    His app must have required some feature that is only allowed in 3.1.

    For all other developers, their apps can be compatible with 2.2.1 and 3.0 as well as 3.1, which can all be targeted under the very latest iPhone SDK on Snow Leopard.
     
  13. HiFiGuy528 thread starter macrumors 68000

    HiFiGuy528

    Joined:
    Jul 24, 2008
    #13
    Don't believe me? Here are two NEW apps on the AppStore that are NOT 3.0 compatible.
     

    Attached Files:

  14. UngratefulNinja macrumors 68000

    UngratefulNinja

    Joined:
    May 9, 2009
    Location:
    Pennsylvania
    #14
    Right, just like some apps need 3.0. But that's not what your original post said. You said Apple was PULLING apps that aren't 3.1 compatible.
     

Share This Page