Apple XServe 1,1 (Late 2006) not seen SATA drivers

Discussion in 'Mac OS X Server, Xserve, and Networking' started by badstorm, Feb 2, 2015.

  1. badstorm macrumors newbie

    Joined:
    Feb 2, 2015
    #1
    Hi,

    i recently got an old Apple Xserve 1,1 (late 2006) that works perfectly. The only thing that doesn't work is that the computer did not detect the hard drive. In this server there is only one sata drive.

    The first thing that I did is to check if the 80gb drive works, so I attached it to my MacPro and it works perfect.

    Since I no have experience with XServe, i notice that on System Profile, the computer detect the sas controller, but not the sata controller. It is correct? There is a way to switch from sas to sata? There is a way to detect if the disk Caddy is broken or the sata hardware is broken?

    Thanks a lot.

    Marco
     
  2. jamall macrumors regular

    Joined:
    Jun 9, 2003
    Location:
    Canberra, Australia
    #2
    If that's an Apple firmware drive that originally shipped with the Xserve, then it sounds like it might be the caddy. I assume you've already tried it in all three drive bays, so unless you have a known working SATA1 drive to test (which may or may not work anyway as the caddies are picky about which drives they will accept) then all you can really do is inspect the SATA interface wires in the back of the caddy. Uncharacteristically, (and possibly the weakest component of the Xserve) these were poorly designed and the connecting wires seem to be stuffed into the small space haphazardly. I've had several frayed wires and one case of the power cable detaching from the caddy completely, so you may be able to spot and repair some damage, but you may have to get a new caddy. Less than $20 on the bay.
     
  3. adam9c1 macrumors 65816

    adam9c1

    Joined:
    May 2, 2012
    Location:
    Chicagoland
    #3
    Can you elaborate on the Apple Firmware drive thing?

    I was working with an XServe back in the day and I had issues when using non factory drive.
    It would work ok in a USB dock but not in the built in caddy.
     
  4. jamall macrumors regular

    Joined:
    Jun 9, 2003
    Location:
    Canberra, Australia
    #4
    Here's an article about it http://tidbits.com/article/10166 but briefly, long before hard drive manufacturers split their product lines into task-specific categories, Apple took off-the-shelf drives and installed custom firmware which presumably made the drives more suited to 24-7 operation. I still have half a dozen or so original Apple Drive Modules from 2008, and all are still functioning perfectly. The downside however is that you can't just swap any old SATA drive into a caddy and expect it to work. I have an Intel 530 series SSD in one caddy that doesn't appear after a cold start but works 100% of the time after a warm reboot, but haven't been able to get a couple of Samsung 840 EVO SSDs to ever work, and I have a couple of Seagate 2TB drives which only appear in OS X several hours after booting up. I've had more luck with older drives, and spinning platter drives often have jumpers that can slow their SATA2 or SATA3 interface to SATA1 speeds, which can sometimes help. Unfortunately jumpers aren't common on SSDs. Keep in mind that the SATA1 interface is limited to 150MB/sec, about a quarter the read speed of the newest SSDs, so if you've got a free PCI-Express slot you may be better of getting a cheap SATA3 host bus adapter for about $20, or using an external USB 2.0 or FireWire drive. Even a couple of newer USB thumb drives in a software RAID-0 will give you a very snappy boot drive compared to the drive bays.
     
  5. obiwan22 macrumors newbie

    Joined:
    Jul 22, 2002
    Location:
    MN, USA
    #5
    Jumpering down to 1.5 has worked pretty well for me on Seagate drives.

    I do agree that there seems to be a bit of voodoo involved as far as non-Apple drives go.
     
  6. NOTNlCE macrumors 6502a

    NOTNlCE

    Joined:
    Oct 11, 2013
    Location:
    DMV Area
    #6
    I had an issue with SATA drives being recognized when I first got my Xserve. Altemose provided me with THIS link, if you have issues getting drives to be recognized. As far as the controller goes, the Xserve doesn't use a SATA controller, just SATA drives. The drive bays actually use an SAS controller but with SATA drives, just like the Xserve RAID uses IDE drives on a SCSI controller. Weird, right?
     

Share This Page