Carrier AppleCare Replacement iphone 6s (Verizon model) not working in LTE 'data only' mode

Discussion in 'iPhone' started by snowfox16, May 3, 2016.

  1. snowfox16 macrumors newbie

    Joined:
    May 2, 2016
    #1
    I noticed my AppleCare Replacement iphone 6s (Verizon model on IOS 9.0.2) has an issue. On my phone, whenever I do Cellular -> Enable LTE -> Data Only, my phone will go to "No Service". Already tried Reset Networking settings but not able to resolve the issue. Somehow the phone only works in "VOLTE/Voice and Data" mode, but not data only. However my older iphone 6 plus (on IOS 8.4) has no problem doing "data only" mode. Anyone experience similar situation? I also tried my SIM card on my wife's unlocked AT&T 6s plus (IOS 9.0) and it also works, so it is not a SIM problem. I suspect this issue is an 'Replacement' product issue. Earlier this phone also had the international SIM locked issue, which was resolved by Apple Engineering adjusted the activation policy. Not sure whether this 'Data only' not working issue is related or not.
     
  2. I7guy macrumors G5

    Joined:
    Nov 30, 2013
    Location:
    Sante Fe, Azuza, Cucamonga
    #2
    Did you try calling Verizon?
     
  3. snowfox16 thread starter macrumors newbie

    Joined:
    May 2, 2016
    #3
    No I didn't call Verizon or Apple Support yet, because I'm sure they will ask me to update/resinstall latest IOS which will remove the jailbreak (currently on IOS 9.0.2) that I currently have. I have a feeling that the issue is not specific to an ios version, but rather this 'Replacement' phone was not setup properly during re-conditioning in the factory.
     

Share This Page