Apple's guide for developing rails in leopard (question)

Discussion in 'Web Design and Development' started by MacFan26, Jun 14, 2008.

  1. MacFan26 macrumors 65816

    MacFan26

    Joined:
    Jan 8, 2003
    Location:
    San Francisco, California
    #1
    I've done a little work in ruby and I was looking into rails and found this starter guide from Apple: http://developer.apple.com/tools/developonrailsleopard.html

    Everything worked for me so far, but In the section "Jump-Starting the Application" it has you create event scaffolding by doing

    script/generate scaffold event name:string budget:decimal

    But it complains that I don't have the RubyGems, but I ran all the updates, and it tells me my current version is 1.1.1? Anyone possibly know how to fix this? Thanks :)

    thrasher:expenses thrasher$ script/generate scaffold event name:string budget:decimal
    Rails requires RubyGems >= 0.9.4. Please install RubyGems and try again: http://rubygems.rubyforge.org
    thrasher:expenses thrasher$ gem --version
    1.1.1
    thrasher:expenses thrasher$
     
  2. bhess macrumors newbie

    Joined:
    Nov 8, 2007
    #2
    Looking through the commands that the guide specifies, I think there's a possibility that not everything will have been updated to the latest version. Which version of Rails are you running? In the Terminal, run
    Code:
    rails --version
    If you're at anything less than Rails 2.1.0, do
    Code:
    sudo gem update
    and try again.
     
  3. MacFan26 thread starter macrumors 65816

    MacFan26

    Joined:
    Jan 8, 2003
    Location:
    San Francisco, California
    #3
    Thanks, turns out I had ruby installed in /opt/local/bin/ruby and gem and rails are in /usr/local/bin. Oops.
     

Share This Page