Appletalk Issues

macmonkey615

macrumors newbie
Original poster
Nov 18, 2004
18
0
So.... I addressed this problem a few weeks ago but it's arisen again.

I've got an OS9 program (FileMaker Pro) that connects to a Host server to work on databases.

I operate everything else on OS10.2.8 and operate the FMPro in classic at the same time.

This weekend I was having issues connecting to an airport and I (under control panel / Network) created a new location.

Now when I try and query the Dbase from FMPro I get an "Appletalk Port Busy" error and it won't connect.

I've made sure appletalk isn't on in OSX but still nothing. I've tried setting my connection to the old Location which was there before.

Any suggestions?
 

MisterMe

macrumors G4
Jul 17, 2002
10,650
29
USA
macmonkey615 said:
So.... I addressed this problem a few weeks ago but it's arisen again.

I've got an OS9 program (FileMaker Pro) that connects to a Host server to work on databases.

I operate everything else on OS10.2.8 and operate the FMPro in classic at the same time.

This weekend I was having issues connecting to an airport and I (under control panel / Network) created a new location.

Now when I try and query the Dbase from FMPro I get an "Appletalk Port Busy" error and it won't connect.

I've made sure appletalk isn't on in OSX but still nothing. I've tried setting my connection to the old Location which was there before.

Any suggestions?
Why don't you want AppleTalk on in MacOS X?
Why don't you upgrade to the MacOS X version of FileMaker?
 

CanadaRAM

macrumors G5
MisterMe said:
Why don't you upgrade to the MacOS X version of FileMaker?
Ouch. I'll take that one.

Because Filemaker version 5.0-5.5-6.0 has a different data file structure from Filemaker version 3.0-4.0-4.1 and converting an existing database can be anwhere from trivial to a huge job.

Then, Filemaker charges hefty upgrade fees

Then, Filemaker has discontinued version 5.5 and 6, which is the last OS9 compatible version, and Filemaker 7 is (you guessed it) a totally different file structure again with completely new programming and -- more upgrade fees. (You can however buy a FMP7 license and then buy an inexpensive V.6 CD to "downgrade" the license)

Wonderful program, but there is a real issue for those of us with legacy systems who can't get approval for a wholesale upgrade and reprogramming project.

Thanks
Trevor
CanadaRAM.com
 

CanadaRAM

macrumors G5
macmonkey615 said:
Now when I try and query the Dbase from FMPro I get an "Appletalk Port Busy" error and it won't connect.
I've made sure appletalk isn't on in OSX but still nothing. I've tried setting my connection to the old Location which was there before.
Are you able in your version to set both the FileMaker client and host to TCP/IP rather than AppleTalk (Preferences, Application, Networking) and connect to the host that way? If not, turn Appletalk back on for your Airport.

Thanks
Trevor
CanadaRAM.com
 

macmonkey615

macrumors newbie
Original poster
Nov 18, 2004
18
0
Thanks

Thanks for understanding Canada. That is exactly right... First off- The classic machines that the other 16 employees run on do a perfect job and they have for the past 5 or so years. I simply work off my powerbook because I do in-house design and such plus I like the OSX browsers, email etc... much better.

Also we setup FMP7 on a dummy machine and tried to run the existing dbases and the relationships and such were completely knackered. So looked to us that there's no point in pouring over $15K into systems that we were already happy with.

Anyways... i'll try the TCP/IP and let you know.

P.s. I originally turned appletalk off just to see if it may free up the OS9 appletalk port which is conflicting....
 

macmonkey615

macrumors newbie
Original poster
Nov 18, 2004
18
0
Fixed...

Well Canada, I tried the TCP/IP thing and unfortunately I don't believe they have the server configured to show the dbases that way.

I did although go in and From OSX - Erase The new locations that I recently added and set the network location to Automatic - then I turned appletalk On in the Ethernet pref's and vwahla..... It worked.


Thank you for your help.

JW
 

Similar threads

  • Budeezy
0
Replies
0
Views
124
  • andyherman
1
Replies
1
Views
300
Replies
1
Views
286
  • SRASC
5
Replies
5
Views
1K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.