AppleTV 3 Needs Daily Reboot to Play Home Sharing Content

Discussion in 'Apple TV and Home Theater' started by mikesnead, Nov 14, 2014.

  1. mikesnead macrumors newbie

    Joined:
    Nov 14, 2014
    #1
    Our AppleTV 3 has been requiring daily restarts in order to play home sharing content. We are able to see and navigate the shared library with no problem, however, when we select an item to play, we get the spinning loading indicator and nothing ever starts. If we restart the ATV3, things seem to work well for many hours until the issue appears again and another restart is required. We most often play content purchased through iTunes (thus contains DRM) so I've been suspecting it is some sort of authentication issue perhaps.

    All streaming services (Netflix, Hulu, YouTube, Trailers) play without issue.

    The Setup:
    • Apple TV 3 w/ latest OS [Wired Connection to network]
    • Mac Mini MD387LL/A (w/16GB RAM) running Yosemite (iTunes and OS fully updated) [Wireless Connection to network]
    • ASUS RT-N66U (w/ CenturyLink 1Gb/s Internet Connection)

    Thanks in advance for any suggestions/tips!
     
  2. sulliweb macrumors regular

    sulliweb

    Joined:
    Mar 13, 2011
    #2
    Try switching to WiFi. Not sure what's up with the latest update, but mine was having similar issues. Eventually, home sharing just stopped working. I switched to WiFi, and the problems went away.

    Apple's latest updates have some networking issues.
     
  3. Che Castro macrumors 603

    Joined:
    May 21, 2009
  4. mikesnead thread starter macrumors newbie

    Joined:
    Nov 14, 2014
    #4
    Thanks! I shall try wireless for the next several days and report back any findings.
     
  5. DJTaurus macrumors 65816

    DJTaurus

    Joined:
    Jan 31, 2012
    #5
    I tried wifi as many people suggest and the problem fixed for 2 days... today the problem is back... the only solution but not permanent is to rename each time your mac's name from Settings->Sharing. Than makes homeshare to work but you have to do it each time.....
     
  6. Alrescha macrumors 68020

    Joined:
    Jan 1, 2008
    #6
    If this actually helps, then it may be worthwhile to turn off Wake for network access and turn off Enable Power Nap in System Preferences/Energy Saver. Doing that may stabilize things.

    A.
     

Share This Page