Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

AppleTV 4 suddenly stopped playing home shared movies

brian.leveille

macrumors newbie
Original poster
Mar 17, 2007
19
0
I have iTunes on my mac home sharing to my AppleTV 4. Just today, it seems it has trouble playing movies - selecting one just buffers forever.

TV shows from home sharing play fine - I played a TV show and it didn't even buffer! Started playing immediately.

I've tried restarting AppleTV and iTunes (I have not rebooted my Mac yet)

Anyone else see anything similar?

Thanks,

-BL
 

benjitek

macrumors 6502a
Sep 23, 2012
863
452
Take a look at Infuse or Plex if rebooting your Mac and router doesn't help.
 
Comment

brian.leveille

macrumors newbie
Original poster
Mar 17, 2007
19
0
Turned out to be my wireless network - I had hard-coded the channel choices for my airport extreme a long time ago to deal with some interference. Looks like some new interference developed and it killed my wifi performance. I set my AE to be 'automatic' for all channels and everything returned to normal.
 
Comment

whoiare

macrumors regular
Aug 30, 2011
102
14
Take a look at Infuse or Plex if rebooting your Mac and router doesn't help.

thats no help at all. I too have started having weird buffer issues with my home shared movies and tv shows. A simple restart of the ATV4 fixes the issue. It all started with the last software update. My atv is hardwired and the movies play fine on my other ATV3s.
 
Comment

pjarvi

macrumors 65816
Jan 11, 2006
1,289
190
Clovis, CA
On Windows: close iTunes, restart the Bonjour service, re-open iTunes.
On MacOS: close iTunes, restart the mDNSresponder service, re-open iTunes.

I',m not 100% sure if that will resolve the issue on a Mac but have done that on Windows whenever iTunes Home Sharing stops responding.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.