AppleTV and Meraki Wi-Fi Network

Discussion in 'Apple TV and Home Theater' started by rodlouro, Mar 20, 2008.

  1. rodlouro macrumors newbie

    Joined:
    Mar 20, 2008
    #1
    Hi guys,

    I'll be getting an AppleTV early next week and was wondering if it'll play nice with the Meraki Mesh Wi-Fi I have running at the house. Does anyone know?

    I have a wired router linked to the DSL modem, the computers on the first floor and a Meraki Mini. There is also a Meraki Mini extending the range of the wi-fi network on the second-floor (where I'll be installing the Apple TV; there is no wired network up there).

    Anyone have any ideas if the AppleTV on the second floor will be able to access the computers running on the first floor (wired or wireless)?
     
  2. rodlouro thread starter macrumors newbie

    Joined:
    Mar 20, 2008
    #2
    Problems

    Since no one replied I'll report my findings:

    Got the Apple TV installed this weekend, and it works beautifully. However, when it's on the Meraki Wi-Fi network I can only access web content (YouTube, Flickr, Rent Movie, Trailers, etc) I am not able to access my local content (Music, Movies and Photos on my computers).

    It works perfectly if attached to the wired network, accessing both local and web content.

    So I believe the problem is the interface between the two networks (which address the appliances differently). Any one got any ideas? Anyone with Meraki or Mesh experience on-hand?

    Thanks!

    BTW, I can't leave it connected to the wired network because it's not available in my home theater (this is only covered by the Wi-Fi network).
     
  3. MrStevieP macrumors newbie

    Joined:
    Feb 27, 2008
    #3
    What are the subnet masks for the wifi and wired? I take it your main machine is attached to the wired network?
     
  4. rodlouro thread starter macrumors newbie

    Joined:
    Mar 20, 2008
    #4
    MrStevieP, here is the info you asked for:

    Wired Subnet Mask: 255.255.255.0
    Wireless Subnet Mask: 255.128.0.0

    My main PC (an iMac) is actually on both right now.
     
  5. rodlouro thread starter macrumors newbie

    Joined:
    Mar 20, 2008
  6. MrStevieP macrumors newbie

    Joined:
    Feb 27, 2008
    #6
    I think this is probably down to the atv not being able to resolve the mac's addres or there is some obscure port blocking on the wireless.

    Try this - just connect both the mac and the atv *only* to the wireless. If you have already done this, did it have the same result?

    Also you could see if you have any ports blocked on the wireless. The fact that on wireless you can view web contnet means you have a connection and its working, but bonjour or what ever protocol the atv uses to locate macs is not functioning.

    Normally this type thing comes down to ip routing configurations, hence why I suggest placing both on the same network - with the mac on wired and wireless. If this works and then you want to use the atv on wireless and the mac on wired then you need to setup the routing and subnets to allow you to do so. Not sure if your router will allow this - although it is curious they the wireless has a different subnet.
     
  7. guz macrumors newbie

    Joined:
    Jan 27, 2012
    #7
    Possible Solution

    I had a similar problem and was not able to get computers connected to the apple tv even though both my computer and the apple tv were connecting to the internet fine through the meraki network.

    I actually called into the support group at Meraki (great guys by the way, very very helpful) and they let me know the solution.

    Meraki networks are defaulted to NAT mode, if you change your network to "bridge mode" by going to the dashboard, then selecting Access Control under the Configure tab, you can make the change there.

    Save your changes and you're good to go!!

    Hope this helps!
     
  8. mscwheat macrumors newbie

    Joined:
    Mar 17, 2015
    #8
    Meraki and ATV's

    Meraki and ATV's don't play nice for many reasons. But if your committed to making it work this is the deployment information from Apple.

    http://help.apple.com/deployment/ios/#/apd8fc751f59

    First off, Bonjour can't cross VLANS or subnets so it has to be on the same subnet as the user device unless you have the Bonjour Gateway enable in Meraki. "Dont Bother"

    Deployment Best Practices

    Set wireless timeout to 8hrs not 30mins
    Move ATV away from the interfernce
    Peer to Peer Airplay when ever possible reference requirements online
    Don't use channel 149 or 153 - must set manual channel in meraki
    Do connect to LAN whenever possible
    IOS must be on 8
    Yosemite for OSX -
    COmputer 2012 and later
    IOS date 2012
    ATV 7.0 version
     
  9. westrock2000 macrumors 6502

    Joined:
    Oct 18, 2013
    #9
    I find it best to only have 1 router issue IP addresses (through DHCP). Turn off DHCP on all other routers.

    Set your main router to issue within a certain range if possible (192.168.1.1 to 192.168.1.100) and set all the routers just outside that with manually set IP addresses (192.168.1.101, 192.168.1.102, etc).

    Now when a device connects to your wireless access point the wireless AP will relay the IP request to the subnet which your main router will pickup and issue an address. However, once the device gets the IP address it does not need to talk to main router anymore. For instance if you are doing wireless to wireless they do not need to go through the main router at all. You can loose power to main router and the other devices will still function until the DHCP license expires.

    Daisy chaining routers that each issue DHCP just adds all kinds of complications.
     
  10. jxw7802 macrumors newbie

    Joined:
    Apr 21, 2015
    #10
    Fix for meraki and apple TV

    Ok guys, for those who are dying to have a fix to have Meraki work with apple TV. I got ya!

    It's a 2 stage process. :)

    Tested on Meraki MR32 MR 34 and MR18

    #1

    follow this instructions to the T from Meraki.

    https://meraki.cisco.com/blog/2013/10/watch-apple-tv-over-secure-guest-wifi/

    #2 Set Apple TV to static IP address
    general/network/wifi/(whatever you name your wireless network/ configure IP pick manual

    Pick any open IP under 0/32 example \\192.168.1.9
    in Meraki dashboard look at clients under configure and pick anything under .32(Meraki wont allow ranges over .32)
    Subnet mask 255.255.255.0
    DNS (can be looked up according to location and ISP Most of the time it is already pre-configured if you have connected to it before)
    Gateway or router: standard is usually 192.168.1.1 but depends on your router some have 10.10.10.1 or if you have multiple Access points it can be 192.168.2/3/4/5.1 ....all depends on you WAN environment.

    After that is done save and that's it!
    Give it a moment to configure and walla! Done!

    Always restart your apple TV for good measure. =)
     

Share This Page