AppleTV atvusb-creator/xbmc/boxee/softwaremenu issue

Discussion in 'Apple TV and Home Theater' started by Jovian9, Feb 8, 2010.

  1. Jovian9 macrumors 68000

    Jovian9

    Joined:
    Feb 19, 2003
    Location:
    Planet Zebes
    #1
    Tonight I put the atvusb-creator on my :apple:TV. Mine is way out of warranty and we were hoping to be able to add usb-storage to it, use XBMC, and Boxee.

    After doing the patchstick and getting atvusb-creator booted on the :apple:TV I encountered my first problem. The SoftwareMenu portion of the atvusb-creator doesn't work with the latest :apple:TV software. It shows up on the main page of the :apple:TV but you can't do anything.

    So I started doing some research. I found an XBMC debug launcher that is installed via SSH through Terminal on my Mac. I did this and now I had another menu option on the :apple:TV that gave me XBMC and Boxee. I played around with this and it worked fine.

    However; I still had the SoftwareMenu options there that were not working. I found the updated Software and installed it via SSH/Terminal. This worked and allowed me to use the SoftwareMenu. I updated the 3rd party plug-ins and restarted my :apple:TV to enable them. This is where the big problem occurred. After updating I could no longer see the menu screen for anything. If I restarted I saw the entire intro to the :apple:TV and the Apple logo but as soon as it should have gone to the menu the screen goes blank. I can hear the little "beeps" of the cursor moving around when I hit the remote but can't see anything.

    I ended up having to do a factory restore of this :apple:TV in order to get it to work properly again. Before I do the atvusb-creator again is there something I should avoid?

    Also, once I have this installed how do I get it to recognize an external usb drive that contains a bunch of media so I can have more storage?

    Thanks!
     
  2. TuckBodi macrumors 6502

    Joined:
    Jan 10, 2007
    #2
    Yeah, unfortunately, the ATVUSB-Creator still installs an old version of the SoftwareMenu. Davilla, the developer of the patchstick (and bootloader ALL patchsticks use) and one of the main dev's on XBMC and the main dev on the Broadcom CrystalHD card support (1080p), has been busy with those things and his full-time job, so the the patchstick is low priority right now.

    No worries though, as it's an easy fix if you can run a couple of terminal commands:
    1) Patch your ATV with the ATVUSB-Creator like you did before (this allows you to SSH into your ATV from another computer).
    2) Get rid of "old" SoftwareMenu - Via Terminal:
    ssh frontrow@appletv.local (password: frontrow)
    cd /System/Library/CoreServices/Finder.app/Contents/PlugIns
    sudo rm -r softwaremenu.frappliance
    sudo reboot

    3) Then install the new updated SoftwareMenu:
    ssh frontrow@appletv.local
    cd ~/Documents
    wget http://iscripts.googlecode.com/files/SoftwareMenu-1.0b1.run
    chmod +x SoftwareMenu-1.0b1.run
    sudo SoftwareMenu-1.0b1.run
    sudo reboot

    4) After the ATV reboots you should now have a working SoftwareMenu. To get USB storage working, from the SoftwareMenu:
    - install NitoTV
    - and then run Nito's Smart Installer

    Now you should see an external USB drive plugged into the ATV's USB port.
     
  3. TheSeagull macrumors member

    Joined:
    Jan 13, 2010
    #3
    I had the same problem as you and solves it by uninstalling what I last installed using ssh.
     
  4. Tomball macrumors newbie

    Joined:
    Feb 25, 2010
    #4
    I had to use
    sudo ./SoftwareMenu-1.0b1.run
     

Share This Page