AppleTV Firmware 7.2 Update for 3rd Gen

Discussion in 'Apple TV and Home Theater' started by campyguy, Apr 8, 2015.

  1. campyguy, Apr 8, 2015
    Last edited: Apr 8, 2015

    campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #1
    Apple pushed out 7.2 updates for both 3rd Gen ATVs today. Apple indicated it's a "stability and performance" update. Updating mine now...
     
  2. JMEANS macrumors regular

    Joined:
    Jun 9, 2012
  3. campyguy thread starter macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #3
    Update went fine, nothing new as far as I can see.
     
  4. mic j macrumors 68030

    Joined:
    Mar 15, 2012
    #4
    Same here. One of the faster updates I have done. See no changes.
     
  5. thadoggfather macrumors G3

    thadoggfather

    Joined:
    Oct 1, 2007
    #5
    I hope it fixes airplay with music app.

    spotify worked well but music app, nah. constantly fighting it.

    I updated, I literally had nothing to lose
     
  6. Ggvfvgbffbf macrumors member

    Joined:
    Sep 10, 2014
    Location:
    Manchester, England
    #6
    No noticeable changes here. AirPlay wake from sleep still not working reliably...
     
  7. AFEPPL macrumors 68030

    AFEPPL

    Joined:
    Sep 30, 2014
    Location:
    England
  8. goodgodlemon macrumors newbie

    Joined:
    Apr 9, 2015
    #8
    I just updated and it seems it took away the TV app from the top row!
    Did this happen to anyone else?
     
  9. sulliweb macrumors regular

    sulliweb

    Joined:
    Mar 13, 2011
  10. pavelbure macrumors 6502a

    Joined:
    Feb 22, 2007
    #10
    My movie app is gone but the tv shows is still there.
     
  11. Nightarchaon macrumors 65816

    Nightarchaon

    Joined:
    Sep 1, 2010
    #11
    Still not fixed the constant loss of visibility of the iTunes library on the network issue...

    does apple EVER fix know bugs that cause usability issues, or just the ones that might let people jailbreak stuff ?
     
  12. awing23 macrumors newbie

    Joined:
    Apr 10, 2015
    #12
    had the same problem. i went to settings-general-restart and that fixed the missing Movie icon.
     
  13. benji888 macrumors 68000

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #13
    I have been trying to update my ATV3 for a couple days now, and keep getting this error:

    “The Update was not successful.
    The Apple TV update couldn’t be downloaded at this time. Try again later.”

    ?????

    I have updated my iPhone 6, and my MBP, but, still getting this for ATV??

    I'm thinking of trying restore (as nothing else works), but afraid it'll have the same problem, as it will have to download the software in the process.

    Is the server really that busy still, or what the ef is going on?

    ----------

    That error message keeps popping up after hitting OK. It's getting annoying.
     
  14. perezr10 macrumors 6502a

    Joined:
    Jan 12, 2014
    Location:
    Monroe, Louisiana
    #14
    AirPlay is definitely more stable for me now. But I'm not sure how much of this may be due to iOS 8.3.
     
  15. sodapop1 Suspended

    sodapop1

    Joined:
    Sep 7, 2014
    #15
    I'm experiencing the same issue and usually restarting iTunes on my MacBook resolves the issue. With that said, a software update on the ATV side is not going to fix this problem.
     
  16. JMEANS macrumors regular

    Joined:
    Jun 9, 2012
    #16
    Tried updating twice this week and as of this morning got this error again so no success yet?!
     
  17. benji888 macrumors 68000

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #17
    late last night it actually worked, it started out saying it would take 2 hours, but it took more than that, I just left it going and it updated in my sleep, finally.
     
  18. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #18
    Been a couple days. I haven't noticed any change. That said I wasn't (in my usage) experiencing any problems which always scares me to update but it doesn't look like it broke anything for me.
     
  19. Nightarchaon macrumors 65816

    Nightarchaon

    Joined:
    Sep 1, 2010
    #19
    Its either a bug in OSx/itunes or a bug in the apple TV firmware.

    Having to go upstairs, or get out of bed to reboot the iMac every time i want to use the apple TV, or between shows, is what has made me move to using PLEX and the Amazon Fire TV...

    so far apple , since 2008, has driven me away from its tablets and laptops (i now use a cheap £200 lenovo with a keyboard cover that runs full windows 8.1 and has a full day battery charge, its replaced my iPad and Macbook air with a smaller, lighter device) i have a 2011 iMac that i wont upgrade now, i built a PC, the new iMacs are too sealed and i worry about HDD failure and the fact i cant replace or upgrade myself., and being sick of the iPhone battery life over several generations, i have gone to HTC for my phone.

    for me apple has gone down hill a LOT since the Leopard / Snow leopard days , for me, thats when apples software and hardware reached peak usability and stability, now they sell cheap, sealed units, in a shiny case to people who buy as a fashion statement every other year instead of wanting a top quality productivity product that lasts.

    Basically Apple has gone from being Premium Products built well, to cheap Chinese crap built as cheaply as possible and sold at an insanely high margin in a well polished case, the case being the only bit that's actually high quality., Polished Turds.. that what apple means to me now.
     
  20. chalupa_batman macrumors member

    Joined:
    Jul 28, 2010
    #20

    I was having this issue at one point that ended up being a faulty wifi card. Apple replaced it under a replacement program. http://www.macrumors.com/2013/04/15/apple-initiates-replacement-program-for-3rd-generation-apple-tvs-with-wifi-connectivity-issues/
     
  21. Nightarchaon macrumors 65816

    Nightarchaon

    Joined:
    Sep 1, 2010
    #21
  22. andreyirra macrumors regular

    Joined:
    Oct 27, 2014
    Location:
    Mexico
    #22
    Has anyone had problems with the remote?

    I press a button and it's registered because the white light flickers with every press but the AppleTV would act as if nothing was being registered.
     
  23. Snoopy4, Apr 23, 2015
    Last edited: Apr 24, 2015

    Snoopy4 macrumors 6502a

    Snoopy4

    Joined:
    Dec 29, 2014
    #23
    All our movies are there, but only in categories and only on one of the AppleTVS. The kid is watching something right now or I'd do a full reset. This is really annoying.

    Doing a restore. Will see what happens.
     
  24. whtgables macrumors newbie

    Joined:
    Apr 27, 2015
    #24
    Firmware 7.2

    With Firmware 7.2, I'm now experiencing HDCP-related messages / errors with my Denon receiver. I've had this hardware combination for almost 2 years, haven't had this issue prior to the update...

    Anyone else run into the HDCP compatibility error messages with the latest firmware?
     
  25. mw360 macrumors 65816

    mw360

    Joined:
    Aug 15, 2010
    #25
    Did they ever fix that problem with it dropping off the network after sleeping while ethernet is connected?

    Had to change mine to never sleep.
     

Share This Page