AppleTV Network Problems

Discussion in 'Apple TV and Home Theater' started by cflorio, Oct 6, 2010.

  1. cflorio macrumors member

    Jul 3, 2007
    So, I got my new AppleTV yesterday. When I set it up, it worked without a problem. I'm running an airport extreme with the 802.11n for my wireless network (WPA2). The AppleTV during initial setup saw my network and after giving it the password attached and worked great. I played with it a good 90 minutes with no problems.

    This morning I went to use it and it wouldn't come back from sleep. I finally powered it off and back on, and it would not attach to my wireless network no matter what I did. I happen to have a wired port to the location where that TV is (I used to have a hacked tivo that I attached there). It saw my wired network and worked again.

    So, any advice on why it might not be working on the wireless network when it did yesterday just fine? Also, the thing attached at 100Mb/s, and looking at the specs that's all it's going to do. Should I just leave it on the wired connection and don't worry? I'd like the thing to work, it's brand new. 100Mb/s in theory is slower than 802.11n, but will it make any real difference? I've got my mac mini with attached storage on the same wired network at 1Gb/s that will be feeding most of my content.

  2. philipk macrumors 6502

    Jun 11, 2008
    I am not sure if this will help but here is my story.

    I have a Dual Band Airport Extreme which I have set to MAC authentication.

    When my two ATV's arrived I set one up in the family room which is hard wired. The Cat 5 cable comes from the basement to a 4 x switch and then connects to three network devices including the ATV.

    I got it working, got the MAC address, entered it into the Airport Extreme and reset the wireless. Next I took it upstairs to my bedroom and got wireless going. It worked great.

    Next, I got my second ATV going in the family room, got the MAC address, entered it into the Airport Extreme and reset the wireless. I checked the wireless and it work. Then I returned it the wired mode.

    Both units were working fine. SD movies from my iTunes would completely cache in a few minutes.

    At bedtime, I decided to watch a 1/2 hour TV episode in the bedroom. It was slow to start and stuttered. I reset the Airport Extreme and got the ATV working but very slowly.

    The next morning I tried to start another 1/2 hour episode and it wouldn't load as the wheel kept spinning. I went to work and when I got home I did the following.


    I turned off all my network devices. I unplugged my switch and my Airport Express. I reset the Airport Extreme and DSL modem. Then after restarting, I plugged in my switch, then one by one I restarted every network device. I didn't restart my Airport Express as I don't use it much for steaming music. I have four wired and nine wireless devices. Three of the wireless run all the time.

    My guess is reseting the Airport Extreme multiple times caused some network problems. So restarting one by one worked.

    It is also possible the older Airport Express caused the problem but I doubt that.

    Good luck.
  3. DeSouza macrumors newbie

    Sep 28, 2010
    I'm having some trouble too, sometimes my ATV doesnt pick up my computer library, it says to ensure its paired with a computer set to home sharing and my apple ID. This is the case, and the only way I have been able to fix it is to fiddle around clicking on a tv show or movie in my itunes and then sometimes it pops back up on the ATV.

    I have only just moved and i'm still waiting for my internet connection which I think may not be helping things when it comes to Home Sharing and my network playing up, at least I hope its that!!
  4. philipk macrumors 6502

    Jun 11, 2008

    I forgot to mention in my first post.

    I got my 2 ATV's last Wednesday. I reset everything on Thursday.

    They have worked flawlessly for six days.

    One is wired and one is wireless. Both seem to cache at the same speed.

    So my fix worked for me.

Share This Page