AppleTV Network Problems

Discussion in 'Apple TV and Home Theater' started by JonnyAlpha, Nov 3, 2013.

  1. JonnyAlpha macrumors regular

    Joined:
    Oct 30, 2008
    #1
    Hi;

    I have found another post (2012) with the same problem and have bumped it but as its old I thought I'd start a fresh one.

    I have a Jailbroken Apple TV2 which has been working fine however just lately I have been experiencing Network Issues.

    The problems:
    1. The Apple TV can happily access the Internet via WiFi but it cannot access the iTunes and Photo content of my Macbook using Home Sharing. I had recently changed my Apple ID Password so I signed out of the iTunes Store on the ATV and signed back in using the new password however this did not fix the issue.

    2. I cannot Ping the IP Address of the Apple TV.

    3. XBMC on the Apple TV cannot add new file content from my NAS and can intermittently access existing content.

    I did recently upgrade iTunes to 11.2(32) and XBMC to v12.2 Frodo.

    Also my Macbook Pro has been experiencing Wifi problems, occasionally dropping the connection, to fix it I have to switch the Air Port on and off).
    Not sure if this is related??
     
  2. JonnyAlpha thread starter macrumors regular

    Joined:
    Oct 30, 2008
    #2
    Solved

    Sorry guys for wasting your time, looks like a simple re-boot of the Router fixed all of the issues I was having.

    What would have caused the Apple TV to have an issue connecting to the Network but still be able to access the Internet??

    Thanks
     
  3. Mrbobb, Nov 3, 2013
    Last edited: Nov 3, 2013

    Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #4
    Once I was troubleshooting something with some guy over the phone, which is always a challenge. Then after 10 minutes of try-this and try-that, I asked the guy, what the lights on the modem say, and he goes what lights? they all dark! :rolleyes:
     
  4. JonnyAlpha thread starter macrumors regular

    Joined:
    Oct 30, 2008
    #5
    I just love the IT Crowd wish they'd make another series.

    Sometimes we forget the Immediate Action Drills thinking it can't be something that simple!!! I wonder why the Internet still worked but the access to the LAN for the ATV2 did not? I need to research more!!

    Thanks

    ----------

    And I phoned up our IT support the other day when I could no longer Log In to our Office Network, half way through logging the details I suddenly thought - better check the LAN cable, it had been renewed a week or so ago and the technician used connectors without clips so low and behold the dam LAN cable had worked its way loose!!!
     
  5. Mrbobb macrumors 601

    Joined:
    Aug 27, 2012
    #6
    That's why they ask you, pull it, and plug it back in.

    Another time I was flustered with this same problem. Joe Street user doesn't know with ethernet cables, you must hear and feel a solid click, otherwise is no good. The trick with when the nipple is worn and soft is to use a flat screwdriver to open the nipple, and the click will now go solid.
     
  6. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #7
    My guess would be in the DNS handling by your router. Your internal network generally uses a different DNS entry than the internet. Generally you have the internal first, and then the forwarding DNS, secondary (unless you are hosting your own DNS for the entire network and caching external DNS), that way when it doesn't find a resolution on your network it will fail safe to the external DNS to find name resolution.
     

Share This Page