AppleTV not connecting with Home Sharing

Discussion in 'Apple TV and Home Theater' started by Paratel, Sep 12, 2012.

  1. Paratel macrumors 6502


    Jan 26, 2005
    Somewhere in the US
    My sister-in-Law just got a new iMac after previously owning a PowerPC iMac..I know about time right?? Anyway. I set up the new iMac and transferred all her iTunes data to the new mac but I can't get the AppleTV 2gen to recognize that home sharing is indeed turned on. Both are on the same network, it worked fine on the previous mac. I even restored the AppleTV and set it up as new and still it tells me to turn on Home sharing on the mac. Any ideas?
  2. SandboxGeneral Moderator emeritus


    Sep 8, 2010
    This is a common issue among many of us. I usually have to turn the service off and then back on, on both the Mac and the ATV in order to get it to connect again.
  3. PalYawn macrumors newbie

    Oct 17, 2012
    Same issue here. I have 7 appleTV's all looking to connect to one library. Only 5 connect, 2 fail. This is completely random after reboot of computer and iTunes. After days of troubleshooting, I spoke with apple and was told that only 5 appleTV's can connect to one library. They said to turn off home sharing on the appleTV's not in use and the others would connect. This did not work. Very frustrated at this point. Any thoughts would greatly appreciated.
  4. jdblas69 macrumors regular

    Aug 15, 2012
    Did you make sure you authorized her new mac, I think in order to use home sharing the computer must be authorized and attached to her account??
  5. Precision4 macrumors newbie

    Jul 27, 2010
    I has similar problem when I changed routers. I had to play with router settings to get it to connect. I would give you more details but I completely forgot what I changed (sleep deprivation is a terrible thing!)
  6. Wordman macrumors member

    Jan 14, 2010
    I had the same problem. Possible fix here.

    Since installing 5.1 on my Apple TV 2 and Mountain Lion on my iMac, I wasn't able to use Home Sharing properly. This went on for two weeks, so I started looking for a solution.

    On my Mac, I went into System Preferences, and Internet Sharing. Under wi-fi options, I changed the security from WPA2 Personal back to 128-bit WEP, which it was before. You'll notice when you go in that 128-bit WEP doesn't initially appear. But hold the option key and click the security dropdown, and it will. Then set your password, click apply, and you're away. My Apple TV is almost back to normal. Still seems a little slower, but at least it can see Home Sharing now and I can watch what I want again.

    Funny, I still have to turn my Internet Sharing off and on again to get my iMac's wifi working. Mountain Lion seems to have stuffed that right up. But hope the Home Sharing thing works for you.
  7. whooleytoo macrumors 604


    Aug 2, 2002
    Cork, Ireland.
    I'm not sure anyone knows the cause for certain (there may be several issues), so there are many people on different threads with different solutions.

    Such as, using Ethernet rather than Wifi, turning off DHCP, turning off sleep on the ATV and the Home Sharing Mac etc. I had mixed/temporary success with these solutions, so I had mine replaced under warranty and it's been pretty near flawless since.
  8. Wordman macrumors member

    Jan 14, 2010
    The replacement worked perfectly? Wow, that's interesting. Like you, I've heard of various problems with ATVs since the update, and various solutions. But you're not the first to say a replacement did the job.

    It's almost as if the update causes something irreversible. And Apple keeping quiet about the whole issue isn't really helping.

    I'd have had mine replaced, but it's an ATV2 and out of guarantee. And I'm damned if I'd have paid Apple £25 for a one-off support call when they caused the problem in the first place.
  9. whooleytoo macrumors 604


    Aug 2, 2002
    Cork, Ireland.
    In my case, yes.

    Beforehand, I'd tried various solutions which seemed to work, then stopped. I switched to Ethernet from Wifi, and that worked perfectly for several weeks; until an iOS update and that broke it again.

    Since I had it replaced, I haven't had that disconnecting/unable to connect issue. I've had occasional 'unable to play content' errors and now and then a song/video would stop. But I could always just go back and play the song/video again without issue. Even had a few more iOS updates without further problems.
  10. reallyoldman macrumors newbie

    Mar 7, 2011
    How do you get to the preference you are talking about? I only see this

    Attached Files:

  11. lv99 macrumors newbie

    Sep 24, 2008
    Apple allows only 5 devices to be authorized for each AppleID. Why do you expect to share 7 devices with same AppleID on your network?
  12. reallyoldman macrumors newbie

    Mar 7, 2011
    I was able to fix my problem by doing a full Reset on the ATV's software.
  13. RexRay macrumors newbie

    Mar 26, 2015
    This is only true of Macs/PCs. As far as I remember / have been able to discover, an unlimited number of iOS devices can connect to an iTunes Library via Home Sharing, and this would include Apple TVs.

    Per Apple Support's Home Sharing troubleshooting page:

    "Verify system requirements

    To use Home Sharing, you need the latest version of iTunes open on a computer that is not in sleep mode,* and one or more of the following devices on the same home network:
    *Additionally, you should install any available updates for your version of Windows or Mac OS X.
    Another computer using the latest version of iTunes.* You can use Home Sharing with up to five computers. Italics mine - RexRay
    An iOS device with iOS 4.3 or later
    Apple TV (2nd generation) with Apple TV software version 4.2.1 or later
    Apple TV (3rd generation)"

    Troubleshooting Home Sharing - Apple Support

Share This Page