AppleTV sync problems with new computer

Discussion in 'Apple TV and Home Theater' started by tiredboy, Mar 3, 2011.

  1. tiredboy macrumors newbie

    Apr 27, 2009
    I have recently upgraded my macbookpro. I had accumulated a lot of rubbish on my old machine and it had started to play up so I didn’t use migration assistant, I just started again from scratch, installing the programmes I needed. So that I didn’t have any potential issues with registration keys I created the same username on the new machine as the old machine.

    I have a rather large iTunes library (~300GB of music, videos, books and apps) with playcounts and ratings etc. so rather than installing all the files into a new library I copied my iTunes folder from the old machine to the new machine. Syncing worked with the old machine fine and all seems to work on the new computer except that I now can’t sync my 1st gen AppleTVs (2 of them). I have removed the link in the appleTV to the old computer and have tried a series of troubleshooting with the following results (same on both AppleTVs):

    1. When trying to sync I get the “….is not responding. Check that any firewall software running on this computer has been set to allow communication on port 3689." The firewall is turned off

    2. Turn off syncing and just stream – “file type not supported”

    3. Reset AppleTV – no change

    4. Factory restore AppleTV – no change

    5. Unlink and relink – no change

    6. Delete iTunes plists – no change

    7. Delete iTunes application and reinstall (leaving iTunes media folder with all info in) – no change

    8. Create new (non-admin) user account and see if iTunes will connect to AppleTV – syncing and streaming both work (using a couple of TV programmes, movies and songs)

    9. Go back to main user account, move iTunes folder with large library, delete iTunes application and plists, reinstall iTunes, imoport a couple of files into iTunes and reconnect to appleTV – seems to work both streaming and syncing

    10. Close iTunes, rename iTunes library and move original library back, open itunes, relink appleTV – “appletv is syncing” message comes up and stays there for a long time (~2 hours before I quit). When I try to sync a second time I get the port 3689 message again.

    11. Repeated some of the test on Wifi, ethernet to time capsule and direct ethernet connection from appleTV to laptop - no change in results

    12. On at least one occasion all was working over wifi so I thought I had solved the situation (not sure how) but when I then connected with ethernet ready to move more of the library to the appletv and got the 3689 message again.

    I’m not sure how I can resolve this problem. My gut feeling is that there is a problem with one of my itunes database or xml files that might be causing the problem (or something to do with my user settings). I know a possible way round would be to start again from scratch and reimport all my files but I don’t really want to lose my ratings/playlists etc.

    Has anyone got any suggestions?
  2. jeff_siler macrumors 6502

    May 4, 2005
    Have you tried to update to the latest itunes updated yesterday?

  3. Tibits macrumors 6502

    Feb 23, 2011
    I am having the same issue with my new 2011 MBP pro and my ATV1. My iTunes library has synced flawlessly from several other Macs including my 2008 MBP. I have contacted Apple support, but no solution so far. I have reset and tested every variable possible. This is definitely due to some handshake issue between the new MBP and ATV1.

    All OS and software are the most up to date versions.

  4. crusher372 macrumors member

    Jul 8, 2010
  5. VladGrigore macrumors newbie

    Mar 20, 2011
    Crazy But True

    I read somewhere that if you try with your iPhone connected at the beginning of the sync it works. Don't ask me why. I also tried the same thing and it is now syncing. I tried it with iPhone 4, not sure if it works with anything else. Also don't know if will have to connect iPhone every time - am still in the middle of long first sync.

Share This Page