AppleTV Won't Sync with iTunes!

Discussion in 'Apple TV and Home Theater' started by Apple!Fre@k, Mar 23, 2007.

  1. Apple!Fre@k macrumors 6502a

    Jun 25, 2006
    Just got my AppleTV and entered in the code on iTunes in order to pair it up and after I select the content I want synced I click Apply and then Sync. The Sync button then turns gray, showing it has been clicked, and then nothing happens. No transfer starts. What gives?
  2. danr_97070 macrumors member

    Jul 29, 2004
    This is how I've worked around similar problems:

    * Make sure you have your video tagged correctly. This means doing a
    Get Info on the file and making sure it's set to the appropriate type (e.g.,
    "TV Show", "Movie", etc.

    * I setup a Smart Playlist with one for TV Shows and one for Movies that
    picks up all files with the appropriate type.

    * I then setup the AppleTV to synch to those playlists explicitly. When I set
    up the playlists, I had to stop/re-start iTunes to be able to view the
    playlist in the list of playlists that are available for the AppleTV.

    * ...but still some videos wouldn't synch. So, I had to goto the AppleTV
    and select a different library source, then re-synch with the machine
    that contains the library I want to synch with. That forces the AppleTV
    to re-load the information from the synch machine.

    Perhaps someday they'll provide an option to simply forcibly re-load the
    information from the machine running iTunes.

    Yes, this is a lot more work than I had expected to have to do with an
    Apple product. I'm hoping the first software update will address some of
    these issues.

    However, I've also had problems with playlists and synch'ing on the iPod,
    so I've never been really happy with this synch'ing stuff.
  3. Apple!Fre@k thread starter macrumors 6502a

    Jun 25, 2006
    Problem is I can't even sync music nor photos. It won't let me sync ****. It just isn't syncing anything. This sucks **** for an Apple product. Even getting a picture on my TV from the thing was difficult. This is something I expected from Microsoft, not Apple.
  4. Passante macrumors 6502a


    Apr 16, 2004
    on the sofa
    So how do you know its not syncing? Can you view any content on your TV?
    How was it hard to get it to get a picture on your tv?

    Can you tell about your wireless setup?
  5. Apple!Fre@k thread starter macrumors 6502a

    Jun 25, 2006
    Correct. I can not view any content. It just lets me look at trailers and such.

    It was hard because my TV has two component channels. One is for 480P/720P/1080i and the other is for 480i. Because the AppleTV is set to 480i at default I had to figure out how to set the AppleTV to 720P without being able to see the prompts since the AppleTV asks to confirm the resolution size or it switches back. What I ended up doing was hooking it up to the 480i connection, then selecting 720P on the AppleTV, screen went blank and I just pushed down once on the remote and then selected that to confirm. Moved the connections over to the 720P component and I was all set.

    My wireless setup has a Airport Extreme Router located about 65 feet away from the AppleTV. No walls in between, just one set of double doors. The AppleTV is hooked up wirelessly to the Airport Extreme. My computer which I'm trying to sync data with the AppleTV is connected via hard wire Ethernet cable to the Airport Extreme.
  6. Passante macrumors 6502a


    Apr 16, 2004
    on the sofa
    sorry for the basic questions. Is you :apple:TV connected to your wireless network. You can confirm this from one of the setup settings. What wireless encryption are you using? Itunes is open correct.
  7. Apple!Fre@k thread starter macrumors 6502a

    Jun 25, 2006
    Didn't I say that in my last post? ;)
  8. Passante macrumors 6502a


    Apr 16, 2004
    on the sofa
    sorry I made some edits that you may not have read

    Repair permissions on your mac and restart. Open itunes and look for the apple tv icon. See if it starts to sync
  9. Apple!Fre@k thread starter macrumors 6502a

    Jun 25, 2006
    How do I repair permissions?
  10. Passante macrumors 6502a


    Apr 16, 2004
    on the sofa
    spotlight "disk utilities" The interface of the app is straight forward. Improper permissions can cause all sorts of problems. What Mac do you have?
  11. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    I had the same problem. You need to go into iTunes and iPhoto both and enable sharing.
  12. Apple!Fre@k thread starter macrumors 6502a

    Jun 25, 2006
    You're the man! It worked. Thanks! Had to configure my firewall to allow certain sharing, too. This is MUCH more work than I expected from an Apple product and definetly not something that would be easy for the computer illiterate but at least we're cookin' now. :)
  13. nsbio macrumors 6502a


    Aug 8, 2006
    Sounds like the plain old cable would have done the job with zero hassle and no loss of functionality. I wonder when will they come up with the Electric Spoon, a device that requires batteries in order for you to eat soup and updates itself over the wireless.

    Normally, the update would be automatic, but you can also set it up, through a dedicated control panel, to update it manually, for "better control and feel". First three months of support would be included in price. Batteries sold separately....
  14. MacBoobsPro macrumors 603


    Jan 10, 2006
    I havent got mine yet but I read the manual on To set the resolution when you cant see anything I think you hold down menu and press the up arrow on the remote to scroll through the settings. Dont hold me to that go check out the manual.
  15. sner66 macrumors newbie

    Mar 24, 2007
    Hinsdale, IL
    see my post (#15) in this thread. (pasted below)

    Well, it worked flawlessly out of the box for me- amazing for a networking product( with WPA to boot!). BUT then when I tried to re-sync after adding some new content to my library it would just "hang" and sit there with the little whirrly sync icon, but nothing happened. I think I finally figured it out. I have a laptop with both a wireless card and I also leave it plugged into my home lan via an ethernet cable. Even though the ATV is not connected to the LAN via the ethernet port, iTunes must somehow get confused since it senses the connection in the pc.

    To avoid the problem, just detach the hardwired connection and use the wireless connection alone. I don't know if this helps anyone, but it would have saved me about six hours of frustration had I known about it
  16. fakename macrumors newbie

    Mar 25, 2007
    Firewall Settings

    I had the same problem and searched online for hours for someone with the same problem but couldn't find anyone since aTV had only been out a few days I guess. I was so frustrated, never had any problems with apple products.

    Finally hit me the next morning (with a good nights sleep) when I was going to try for one more hour to get the thing to work before I returned my "defective" aTV... DUH, THE FIREWALL!!!

    Note to self: don't start any new hardware setups after midnight, no matter how simple it should be.

    Apples troubleshooting documentation does mention firewall settings in some of the sync problems but not in the specific instance I had so I wasn't even reading those articles because I thought it was unrelated. Apple should simply have a "iTunes sees my device but I still can't sync my files."

    I thought I was setup right since I had sharing enabled in iTunes BUT I did not have the Firewall sharing setup.

    System Preferences > Sharing > Select Firewall > Check iPhoto and iTunes Sharing

    Finally started syncing but was REALLY slow so I decided to start over cleared everything out and back to factory settings and unpluged. Even reset iTunes cleared out aTV stuff that had been setup in prefrences. Plugged back in and started from scratch.

    Bada Bing Bada Boom, it just works... now.

    Much faster sync and started watching stuff locally after ony a few minutes.
    You also don't need sharing enabled in the iTunes preferences so you can still keep thant off if you prefer. The firewall sharing was my issue.
  17. sandman42 macrumors 6502a


    Oct 23, 2003
    Selecting video resolution when you can't see the output

    There is an easier way. If you hold down 'menu' and '+' on the remote the Apple TV will cycle through video resolutions, then you can click 'play/pause' (center button) when you get to the one that works. It's buried on page 40 of the manual.

Share This Page