AppleYukon2/Ethernet seems to kill the kernel :(

Discussion in 'macOS' started by RS1999ent, Oct 9, 2008.

  1. RS1999ent macrumors member

    Joined:
    Oct 9, 2008
    #1
    Hi,

    I'm pretty new here; I recently purchased a new macbook pro at the end of August. Unfortunately, my experience so far hasn't been too good. Every day, or perhaps every few days, my laptop will freeze completely. The mouse pointer will suddenly change from a pointer to a spinning beach ball, I won't be able to open any apps, won't be able to ssh in to it, or ping it. Even force-quit cannot be used. My only recourse is to reboot the machine.

    After digging a bit, it seems that this problem has something to do with either Apple's ethernet driver or chipset. The last entries in the system log look like:: "Apple Yukon 2 <memory address>? sk98osx sky2 -- sk98osx_sky2::replaceOrCopyPacket tried N times." I've copied and pasted the relevant lines from the system log at the end of this message.

    Does anyone have any experience with this? I tried to search for the error on google, but didn't have much luck. Some people have reported problems with the older Apple Yukon drivers (not the Yukon2 version). Others have seen this problem when running the bit torrent client "Transmission"; their solution seems to have been to stop using that specific client. None of these are applicable to me, as my laptop freezes regardless of what apps I'm running. Regardless, this seems like a pretty low-level kernel or driver problem.

    I guess I could always ask Apple to repair it, but that would leave me without a primary machine for at least several days. I haven't found a deterministic way to reproduce this problem, so I'm worrie that Apple's solution will be to tell me to reformat my hard drive and "hope that the problem does not occur again."

    btw, Apart from macports, I really don't have any non-standard software installed.


    Thanks for any comments or suggestions you guys might have :)

     
  2. RS1999ent thread starter macrumors member

    Joined:
    Oct 9, 2008
    #2
    I confrimed the problem is with the wireless driver. The laptop does not freeze if I use the wired connection. I guess my mode of usage of the laptop doesn't coincide much with Apple's driver testing process...

    Anyway, just wanted to post a reply in case anyone else runs into a similar problem. Specifically, it seems like if you leave a lot of TCP (specifically, ssh windows in my case) connections open for a day or so, the wireless driver eventually crashes and kills the kernel. The net result is a non-responsive laptop and, well, the spinning beach ball of death.
     
  3. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #3
    This sounds kind of like a bug I recall seeing complaints about in earlier versions of 10.5. Are you up to date on Software Update?
     
  4. RS1999ent thread starter macrumors member

    Joined:
    Oct 9, 2008
    #4
    yep, I'm completely up to date with Mac OS 10.5.5 and any additional updates that have been released since the 10.5.4->10.5.5 update. I saw the problem when I was running the OS my laptop shipped with (10.5.4) as well.

    Maybe I'll call apple's support line this week to see if they know anything...
     
  5. Perdix macrumors newbie

    Joined:
    Aug 31, 2004
    Location:
    Scotland
    #5
    Did you make any progress on this?

    My iMac has been doing it - crashing randomly, everything slowly freezing, giving the message:

    06/03/2009 18:45:08 kernel AppleYukon2: 00000000,00000001 sk98osx sky2 - - sk98osx_sky2::replaceOrCopyPacket tried N times

    It does it about once a week. Hardware check runs fine, I'm up to date with software etc.
     
  6. ybrise macrumors newbie

    Joined:
    Mar 11, 2009
    #6
    Hi,

    I'm having the same problem with slightly different system log entries though. I'm sorry not being able to provide a solution, but I thought I'd join the effort of looking for one :)

    My system:
    MacbookPro, 2.16 GHz Core 2 Duo, 3GB RAM
    OS X 10.5.6 (completely up to date)

    Ok, so first of all, here's an excerpt from my system.log:

    You can clearly see that there are two AppleYukon2 related messages, one just before sleep and the other just after wake up. After that it only takes a few seconds (or basically a first action I do) and then the pinwheel of death occurs and all applications freeze. I can still move the mouse though. Only a hard restart solves the problem.

    What I've tried so far:
    1. Running single user fsck and memtest -> everything ok.
    2. Uninstalling suspicious applications/widgets (i.e. iStat widget)
    3. Resetting PRAM and SMC
    4. Creating a new user and see whether the problem exists there -> yes.
    5. Trying to reproduce the problem with different peripheral setups (battery/no battery/only battery, external keyboard & mouse plugged in / out). I can't remember exactly if I tried all the combinations, but the problem seems pretty persistent.


    What is AppleYukon2 anyway? The driver for wireless? I'd be so grateful if anybody has any suggestions. I don't want to do a fresh install.

    I hate this thing! It's such a joy killer, because in general I love my Macbook, and I've been bragging about OS X's stability to Windows people, but no more...

    Gruss,
    Yves.
     

Share This Page