Application Launch adds Blue Tint to Screen

Discussion in 'MacBook Pro' started by bpletcher, Aug 2, 2012.

  1. bpletcher macrumors member

    Joined:
    Jun 16, 2011
    Location:
    Michigan
    #1
    Hi iv been searching online for a solution to my issue but to no prevail.

    When I launch certain applications (i.e. Photoshop, VMware Fusion) it gives my screen a blue tint. Its nothing too noticeable but still enough to irritate me because I know it shouldn't be there.

    During my searches most issues involved with there screens going to sleep and when woken up they have the blue tint. This is not the case for me. When I open up a specific app I can see the tint added but once I close out of it I see it go back to normal. I am about to bring it in to Apple to see whats wrong but was hoping I could save myself the hour trip if there is a relatively simple solution. Any information or help would be greatly appreciated!

    Thank You
     
  2. sweetbrat macrumors 65816

    sweetbrat

    Joined:
    Jun 17, 2009
    Location:
    Redford, MI
    #2
    I know I've seen a post about this somewhere on the site. I think someone figured out it was the graphics card...whenever the discrete card kicked in, it gave the screen a slightly blue tint. I could be remembering wrong, but I'm pretty sure that's what it was.

    If you have gfxCardStatus installed it can tell you which card is being used, and you can see if that's what's causing it.
     
  3. shigatashway macrumors member

    Joined:
    Aug 29, 2011
    #3
    I was having the same issue. Go into the power savings section and turn off automatic graphics switching and then restart the machine. This fixed it for me, and I was able to then reenable graphics switching without issue.
     
  4. bpletcher thread starter macrumors member

    Joined:
    Jun 16, 2011
    Location:
    Michigan
    #4
    You guys are incredible and a life saver! This worked like a charm and definitely had something to do with it. When I unchecked the automatic graphics my screen instantly had the blue tint. After a restart with it unchecked the screen looked back to normal so I rechecked the automatic graphics and no tint! I just hope that this doesn't become an occasional thing I have to do.

    Thanks again for all your help!
     
  5. shigatashway macrumors member

    Joined:
    Aug 29, 2011
    #5
    Question for you: Do you play Source-based games like Portal/Team Fortress/L4D2?

    I have a hunch the issue is steam related - as I have in the past had horrible issues with Source based games through Steam (and notice that even with this fix, launching Portal 2 causes the screen to turn blueish)
     
  6. engemasa macrumors newbie

    Joined:
    Aug 1, 2013
    #6
    It's a setting under 'Energy Saver'.

    Goto: System Preferences > Energy Saver. At the top of that you will see "Automatic graphics switching".

    If this is checked, the system will switch graphics mode to save your battery life. Basically it modifies the color appearance on your screen so that it uses less energy.

    If this is not checked the system will not modify the graphics mode so that you're always going to see the best colors possible... At the cost of battery life.
     
  7. YellowDzn macrumors newbie

    Joined:
    Aug 3, 2013
    #7
    Hi, I've seen this answer so many times the "Energy saver > Automatic graphics switching" But for me I don't see the checkmark for graphics switching, I am running on 10.7.5 so it may be that I don't have mountain lion, but the problem persists when I'm on steam, and seems to only happen when I try to play source based games (Day of Defeat, Counter-strike, Portal, ect...) as he said earlier, I found the temporary fix was to tab out of the game, go to system preferences > display > color and it would pop back to normal but as you can probably tell that's a big time waster when all I want to do is play a game. I don't want to do that every time. Any help is appreciated. :]
     
  8. zacnoo macrumors newbie

    zacnoo

    Joined:
    Feb 12, 2013
    Location:
    Cyberspace
    #8
    That's not true, that setting enables the switching of integrated graphics to discrete graphics according to what sweetbrat said. It's to enable the switching to the higher performance discrete card, when needed, and to the energy saving integrated card, when needed. In settings somewhere, the color scheme for each card must be set differently for each card.

    As for games, this isn't only for people with switchable graphics. Source games (or at least Counter Strike: GO) override the system color scheme, you can change the color scheme in game but both of them aren't the same as the system default.

    It's probably because you have a Mac that doesn't have switchable graphics, like the Macbook Air or newer MBPs.
     
  9. poematik13 macrumors 6502a

    Joined:
    Jun 5, 2014
    #9
    When you run a source game, it switches the color space. It happens to me all the time on TF2.
     

Share This Page