"Application Not Compatible" error message

Discussion in 'iOS Apps' started by ryketech, Jan 11, 2010.

  1. ryketech macrumors newbie

    Joined:
    Oct 15, 2009
    #1
    Alright, here's the deal. When I try to down load certain apps on my ipod touch I get this error message saying I need an iphone software update. My gf doesn't get this message with her ipod touch.

    Anyone know a fix for this?
     
  2. daveishere macrumors 6502a

    daveishere

    Joined:
    Dec 2, 2008
    Location:
    UK
    #2
    Maybe you're running a game that requires the 3.0 software update and you're not running that software version? If you've got an iPod touch you may need to pay a small fee to update to this.

    and for anyone who says that its a rip off that ipod touch users have to pay for the software updates whereas iphone users get it for free, if anything iPhone people are paying more for the update as we pay for it through our (expensive for what we get) monthly bills.
     
  3. fishkorp macrumors 68020

    fishkorp

    Joined:
    Apr 10, 2006
    Location:
    Ellicott City, MD
    #3
    Or it can be an issue of first gen vs second gen iPod Touch too. Developers are given the choice of which devices an app/game is compatible with.
     
  4. ryketech thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #4
    Ooooh, I bet it was the $5 update I so blatantly ignored a few months ago. Oops...
     

Share This Page