Application Not Compatible "This application requires the iphone 3.1.2 Software)

Discussion in 'iPod touch' started by lPHONE, Apr 23, 2011.

  1. lPHONE macrumors 6502a

    lPHONE

    Joined:
    Nov 17, 2009
    #1
    Of course, when I connect to iTunes and check for update it says "This version of iPod software (2.2.1) is the current version."

    It's a 1st generation 8gb Touch. All I want is the God damn Remote app so I can use it with Airtunes.
     
  2. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #2
    The current version is I think 3.1.3, but there's a bug in iTunes that stops it from offering the update. I've heard that it's possible to force an install of 3.1.3 if you download the update file separately, but I'm not sure where to get it from or how to install it. Hopefully this helps to put you on the right track though.
     
  3. lPHONE thread starter macrumors 6502a

    lPHONE

    Joined:
    Nov 17, 2009
    #3
    Is it the same 3.1.3 that iPhone uses? Because I have a copy of that!
     
  4. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #4
    No. I'd post you a link to download the file, but because its a paid update, I can't.

    Do a Google search for it, then once its downloaded, press Shift on Windows or Option on Mac, while clicking the Update button for your iPod in iTunes. Select the file you downloaded from the internet and update your iPod.
     
  5. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #5
    I forgot about that! Yet iTunes apparently won't let you pay for it anymore.

    If I was in this situation then I'd contact Apple and see whether there's an official fix.
     

Share This Page