Application suddenly not opening... what to do?

Henri9009

macrumors newbie
Original poster
Jun 21, 2011
20
0
Montreal
Hi to all!

An FTP application I've been using for years... I used it yesterday without any problem.

Suddenly this morning, when I tried to open it, I got a message like this from the Finder (just another application, I took this image on the Web). Since then, nothing is happening when I try to open it.

I tried to download the last Mac version of the application, but it seems I can't install it. I don't have the proper OS version.

Extra question: Apple is not offering me an OS update... iMac is too old? Mid2011.


I tried with a TimeMachine backup of the application, not working either.

I'm confused... how can this happen when I did absolutely nothing.



Thank you!

Screen Shot 2020-02-04 at 12.05.58 PM.jpg
 

NoBoMac

Moderator
Staff member
Jul 1, 2014
2,646
1,014
What OS version?

Also, what messages are you seeing from the program in Console.app?

What you've provided, no real information to go off of. Eg. might have some corruption, missing library, other.