application updates don't install

Discussion in 'iPhone' started by manhattanmania, Jul 26, 2008.

  1. manhattanmania macrumors regular

    Joined:
    Jul 9, 2007
    #1
    im starting to get really annoyed with this...

    i have downloaded updates (manually, because itunes and my iphone don't seem to be realizing when updates for apps are available) for numerous apps and when i DL them (in itunes), the apps don't actually get updated! the only way i've been able to update apps is by deleting the app and the re-downloading the new version.

    EDIT: now this isn't even working. i tried deleting AIM and reinstalling the new version (1.1) and it will only give me 1.0, even tho when i checked for updates AIM came up.

    am i missing something? shouldn't it just be installing the update over the existing app?

    also, didn't apple say that itunes and/or iphone would automatically let us know there were updates available? neither has been doing that for me.

    any help would be appreciated...
     
  2. extraextra macrumors 68000

    extraextra

    Joined:
    Jun 29, 2006
    Location:
    California
    #2
    My iPhone/computer tells me when updates are available and I can update through iTunes fine. When I try to update an app OTA (using wifi) my phone freezes. :( :confused:
     
  3. manhattanmania thread starter macrumors regular

    Joined:
    Jul 9, 2007
    #3
    im happy for you!

    the only way i got it to work was to delete AIM off my iphone then redownload it there. it downloaded the new version.
     
  4. Sincereh2001 macrumors member

    Joined:
    Apr 30, 2008
    Location:
    Nashville
    #4
    This might be a dumb question, but how can you tell which version of the app is installed on the phone? Isn't it just the same updated version that's in iTunes?
     
  5. terrrrrible macrumors regular

    Joined:
    Jun 17, 2007
    #5
    Yeah... I just saw that happen with AIM for me. I am going to try and delete it from iTunes then redownload it and resync.

    Still downloads 1.0.
     
  6. FSUSem1noles macrumors 68000

    FSUSem1noles

    Joined:
    Feb 23, 2006
    Location:
    Ft. Lauderdale
    #6
    The AIM updates were driving me crazy, the updates would always cause conflicts with the AIM app, so to solve the problem I just uninstalled AIM and I'm done with it.. it's really not worth the hassle.
     
  7. terrrrrible macrumors regular

    Joined:
    Jun 17, 2007
    #7
    Yeah, I've tried totally deleting the program from iTunes and redownloading it, but it still seems to download 1.0, even though in the store it shows 1.1.
     
  8. manhattanmania thread starter macrumors regular

    Joined:
    Jul 9, 2007
    #8
    just to note, this happens to me w/ any application, not just AIM. that was only an example i used... rawr apple.
     
  9. DiamondMac macrumors 68040

    DiamondMac

    Joined:
    Aug 11, 2006
    Location:
    Washington, D.C.
    #9
    I have actually had this problem with my original iPhone

    I uninstalled the program from iTunes and synced it to the iPhone to remove it

    Then re-downloaded it and installed it again with the update

    Works fine
     
  10. terrrrrible macrumors regular

    Joined:
    Jun 17, 2007
    #10
    I'll have to try that later. I tried actually deleting the file in Finder and removing it from iTunes, closing iTunes, opening it again and re-downloading it, but I still got 1.0 for AIM.
     
  11. terrrrrible macrumors regular

    Joined:
    Jun 17, 2007
    #11
    Didn't work for me... after I removed it from my phone and re-downloaded AIM, it still showed it as 1.0 afterwards.

    Seems to be working now... iTunes just doesn't recognize that it has the latest version I guess.
     

Share This Page