Application wont start/install on device for testing

Discussion in 'iOS Programming' started by tutiplain, Nov 14, 2011.

  1. tutiplain macrumors member

    Joined:
    Feb 4, 2011
    #1
    Hi all,

    I am trying to get my app to run on my device to test it, but when I click Run on XCode it says "Build Successful" then "Finished running on device", and yet, nothing happens on the device. I have googled up this problem and everyone seems to have solved it in a different way, but none of those solutions worked for me. Here's what I've tried so far:

    - Reset all my certificates and provisioning profiles.
    - Reset my Mac
    - Disconnect/reconnect iPod from Mac.
    - Reinstalled XCode.
    - Selected proper Certificate under "Code Signing" in Build Settings.
    - Verified that both armv6 and armv7 architectures are available under Build Settings.
    - Verified that "Deployment target" is set to the same iOS version as my device (4.2). An additional note: iTunes won't let my upgrade further than this version, so I think it might be related (my iPod Touch is a few years old).
    - My device name appears on XCode where one select the run Scheme. Before it said "iOS Device" until I reset my certificates on the developer portal.
    - Someone in another forum with the same problem said he solved this by enabling "accelerometer" under "Required Device Capabilities". I could not find such a setting either in Build Settings or my info-plist file.


    If anyone has ever experienced anything similar to this, any help would be greatly appreciated. Since no error messages are reported, I have absolutely no idea about how to go about solving this. Nothing is shown in the device logs, either.
     
  2. nickculbertson macrumors regular

    nickculbertson

    Joined:
    Nov 19, 2010
    Location:
    Nashville, TN
    #2
    That sucks. Unfortunately, I don't have a solution for you but if I had your problem I would try to borrow a device from someone to see if that is where the problem exists. Good luck!

    Nick
     
  3. tutiplain thread starter macrumors member

    Joined:
    Feb 4, 2011
    #3
    Thanks for your reply. I'll if I can borrow one from a friend, and report back what I find.
     
  4. Sykte macrumors regular

    Joined:
    Aug 26, 2010
    #4
    Is iTunes running a sync on the device? This will can cause this particular problem. Does iTunes see the device.
     
  5. tutiplain thread starter macrumors member

    Joined:
    Feb 4, 2011
    #5
    I can sync with iTunes, but no, no sync is happening while I'm testing the app from XCode.
     
  6. jnoxx macrumors 65816

    jnoxx

    Joined:
    Dec 29, 2010
    Location:
    Aartselaar // Antwerp // Belgium
    #6
    Have u tried building an IPA with a distribution profile, and drag it on your device while on the Orginizer, if that doesn't do it, i'm out ;p
     
  7. tutiplain thread starter macrumors member

    Joined:
    Feb 4, 2011
    #7
    Hi again,

    I decided to recheck everything, and I finally solved it. It seems that while both armv6 and armv7 were listed under "Available Architectures" under Build Settings, I was missing armv6 under "Architectures" a setting just a few items up from "Valid Architectures". Its default value is "$(ARCHS_STANDARD_32_BIT)". Simply adding it there solved the issue.
     

Share This Page