Applications Delete Themselves

Discussion in 'macOS' started by KevinAKC, Jul 21, 2008.

  1. KevinAKC macrumors newbie

    Joined:
    Feb 18, 2008
    Location:
    London
    #1
    This is a very odd problem.

    I was using my Powerbook yesterday and noticed that a couple of PDFs I had on my desktop had the generic white file icon, and double-clicking them resulted in OS X not being able to find an application to run them. So I checked my Applications folder and Preview was missing!

    Luckily someone I know has exactly the same laptop so I just copied the Preview.app file from them.

    Anyways, today I plug in my iPod, which is set to automatically update any new photos that I've added to iPhoto. Except.... I got an error claiming that I had no suitable photo application, and was asked if I'd like to reset my photo sync info. And once again, the relevant application, here iPhoto, had been deleted from the disk!

    I've not done anything on the computer recently that would cause a major change of behaviour such as this - I've just been using it as normal!

    Any ideas then please let me know, as I don't wanna lose all my apps!!

    PowerBook 12" G4 1.5 GHz
    OS X 10.5.4
     
  2. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #2
    It is more likely that your are having hardware issues causing the locations of those files to go missing? That, or someone has loaded a script on your system to delete .app files.

    TEG
     

Share This Page