Applications folder crashes Finder (for one user only)

Discussion in 'macOS' started by MacBiscuit, Feb 11, 2008.

  1. MacBiscuit macrumors member

    Joined:
    Jun 27, 2007
    #1
    Don't know if anyone can help me...

    My main user account went haywire at the weekend - dock disappearing and Finder cycling and rebooting every few seconds. I fixed those issues by trashing the dock and finder .plist files, and all appears to be well except...

    I cannot access the Applications folder without the Finder crashing. All other folders appear fine.

    - I can access the Applications folder using another user
    - I can access the apps themselves from spotlight
    - I tried trashing .DS_Store - no difference.

    I'd appreciate any ideas before I go back to 10.4 in disgust (this isn't the first issue I've had - my XP laptop is more reliable)

    Thanks
     
  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Do you have any theme changers installed? Do you have any apps that are only installed on this account? Do you have FileVault enabled? :)
     
  3. MacBiscuit thread starter macrumors member

    Joined:
    Jun 27, 2007
    #3
    Thanks for the response... in answer to the questions

    No theme changers
    No apps specific to this user, though there could be permission issues here - all were installed under the user with the issues.
    No filevault

    Managed to briefly get it working again by accessing the folder using a different user, then trashing .DS_Store again, but I'm now back to square one... It's really odd.

    Interestingly when I previously moved half the apps to a new folder under Applications, and half to a different folder, BOTH new folders became inaccessible (but now the Applications folder was accessible), so it's clearly more than one file in there causing Finder to crash. Really odd...
     
  4. MacBiscuit thread starter macrumors member

    Joined:
    Jun 27, 2007
    #4
    Dug up crash log...

    This is what I get when trying to open the Applications folder, anyone have any ideas?

    Feb 12 08:55:09 Macintosh ReportCrash[180]: Formulating crash report for process Finder[172]
    Feb 12 08:55:09 Macintosh com.apple.launchd[98] ([0x0-0x18018].com.apple.finder[172]): Exited abnormally: Segmentation fault
    Feb 12 08:55:10 Macintosh ReportCrash[180]: Saved crashreport to /Users/joe/Library/Logs/CrashReporter/Finder_2008-02-12-085507_Macintosh.crash using uid: 503 gid: 20, euid: 503 egid: 20
    Feb 12 08:55:10 Macintosh /System/Library/CoreServices/coreservicesd[60]: SFLSharePointsEntry::CreateDSRecord: dsCreateRecordAndOpen(joe's Public Folder) returned -14135
    Feb 12 08:55:10 Macintosh /System/Library/CoreServices/coreservicesd[60]: SFLSharePointsEntry::CreateDSRecord: dsCreateRecordAndOpen(Claire's Public Folder) returned -14135
    Feb 12 08:55:11 Macintosh /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lssave[185]: Wrote corrupt store file /Library/Caches/com.apple.LaunchServices-023503.csstore_corrupt
     
  5. disdat macrumors regular

    disdat

    Joined:
    Jul 21, 2005
    Location:
    New England USA
    #5
    oh wow, I have been going crazy with this same issue.

    I just purchased a copy of Leopard for my MBP. I installed three times - erase & install for the first two times, then a complete zero-erase (7x) & install for the third time. Every time the same problem.

    When I try to access the Applications folder, Finder crashes & restarts.

    I also have a problem in System Preferences>Keyboard. If I access the Keyboard shortcuts tab, as soon as I click anywhere else, Sys Prefs crashes.

    Sometimes if it crashes more than a few times, the menu bar disappears & I have to shut down using the off button.

    Anyway, I called Applecare, and they sent me out a new set of (2) install disks for my MBP and would you believe it. I just installed tonight, and sure enough, the SAME problems!!

    I haven't done one thing. No other installs, just set up my single account. I haven't tried creating another account yet.

    I will give Applecare a call tomorrow, but it doesn't sound like they know what to do.
     
  6. disdat macrumors regular

    disdat

    Joined:
    Jul 21, 2005
    Location:
    New England USA
    #6
    I just tried creating a new admin user, and same errors.

    I am getting frustrated as well.
     
  7. Ellis macrumors newbie

    Joined:
    Feb 24, 2008
    #7
    Possible solution

    Today I had installed an application using their GUI to drag and drop the app into my applications folder. The application opened and worked just fine. However, I noticed that right afterwards I was not able to access my Applications folder. It would always crash. I tried rebooting in firewire target disc mode and repairing permissions via another mac, and that didn't help.

    Finally, after rebooting normally, I typed the application's name in Spotlight and selected "Show all." I was able to see the icon for the app in the Applications folder so I selected it, and moved it to the trash. Then I securely emptied the trash (I may not have had to be that hardcore, but figured it wouldn't hurt). After that, I was able to open my Applications folder just fine.

    Perhaps its an issue with some application's installers not performing good garbage collection, or simply causing a conflict in a plist file, but getting rid of the app works. Its a reputable app (works great on my Powerbook, and I don't want to give them any grief) but I can't let it crash my App Folder either.

    Hope that helps someone out there.

    Pete
     
  8. disdat macrumors regular

    disdat

    Joined:
    Jul 21, 2005
    Location:
    New England USA
    #8
    Thanks for your post, Pete.

    It helps to know that others are having the same issue.

    I will have to mess around with a few pref files. I also would like to install Onyx or something, but I don't know if it will install properly, since I cannot tell which app is causing the issue.

    It stems from the files installed during my OS X install. sigh.

    Going to call Applecare again tomorrow. maybe I can meet with a genius.
     
  9. disdat macrumors regular

    disdat

    Joined:
    Jul 21, 2005
    Location:
    New England USA
    #9
    Here is an update, don't know if it will help anyone else.

    I had an appointment with Apple Genius for yesterday, so I wanted to wipe the drive again, and reinstall Leopard again. Plus I removed the 3rd party ram (from OWC)

    Anyway, long story short, I re-installed Leopard yesterday, and lo & behold there was no longer an error with the Applications folder

    hmm, curious. The only difference in this install was I was using Apple ram, there was no custom install (I installed the default), and I changed the user name.

    So, I canceled my Apple genius appointment, and did some more experimenting.

    I added the OWC ram back, and re-installed Leopard again (I think this is #6) and installed the default (non-customized) with the same user name.

    No luck, the applications folder crashed again.

    So, this leads me to believe it is the ram, right? So I called OWC.

    They suggested running some ram tests, which I am in the middle of doing today. I am using Rember.

    I ran the test all through the night and it appeared to show no errors, but the app couldn't test the full amount of 3 gb, so I removed the apple ram, and stuck the OWC ram in the first slot so it would be tested.

    Also, I changed the prefs so it shuts down all apps, including Finder to test as much ram as possible.

    I will know more later tonight when I get home from work.
     
  10. disdat macrumors regular

    disdat

    Joined:
    Jul 21, 2005
    Location:
    New England USA
    #10
    Well all tests passed. I am not sure what to do now.
     
  11. Sain7 macrumors newbie

    Joined:
    Nov 22, 2008
    #11
    Workaround

    In your home folder, set the layout to "columns" using the button at the top. Then try the following;

    View --> Show View Options --> Show icons (off)

    This causes it to behave for me. A very irritating problem, and apparently comes hand in hand with the Preference crasher thing; when I try and access Desktop and Screensaver it hangs and crashes.

    Edit: By toggling the icons and sorting through the Apps folder by splitting it up until I found the one program that hung Finder when I tried to turn icons on, I've found the problem for me was the application "Spaces". I put it in a folder of its own within Applications and it's now letting me use the folder as normal.

    I did want to go in, open the package, and see what was up with the icon but predictably it hung every time I tried to do that (icons on or off). Might have something to do with the icon or with it calculating size...
     
  12. TC93 macrumors newbie

    Joined:
    Nov 25, 2008
    #12
    Thanks Sain7 it worked for me!

    Wow! Sain7 thanks for the advice, I was really panicking as I had the same problems, but so far, just by turning off the icons as you suggested, I can access my Applications folder.
    I have yet to single out which one's been causing the prob but at last after a few nights of worry, I am feeling better! Thanks again. :)
     
  13. mkindred macrumors newbie

    Joined:
    Mar 8, 2011
    #13
    Wow, Sain7, a couple years after you posted this solution, and it was exactly what I needed. This was driving me nuts.

    Thanks!
     
  14. philipt42 macrumors 6502

    philipt42

    Joined:
    Jun 26, 2009
    Location:
    RI
    #14
    Another few year later: thanks! Worked for me as well.
     

Share This Page