Applications stop working after sync

Discussion in 'iPod touch' started by wunderkind1402, Aug 21, 2008.

  1. wunderkind1402 macrumors newbie

    Joined:
    Aug 21, 2008
    #1
    Hi all,

    I have a problem, every time I sync my ipod touch with the Itunes all the installed application on my device stop working and then I need to remove them and then they work but then I make a sync and they are like damage again :confused:

    I think the problem is coming from the sync and the auto backup.

    If anyone know how to fix this issue please write me back.

    Thanks

    W.
     
  2. cmichaelb macrumors 68020

    cmichaelb

    Joined:
    Aug 6, 2008
    Location:
    Kansas
    #2
    Yeah it happens to me, I've been to the Genius bar twice trying to fix this. But, they claim its hardware related. They won't admit that it's a software issue. I did find a fix that I'm trying out. You will need to do a full restore. You can find the fix here:

    http://arstechnica.com/journals/appl...wngrade-itunes

    Apple discussion forum here:

    http://discussions.apple.com/thread....917930#7917930

    I'm trying this on a pc and so far so good -touch has been stable for about 24 hrs. now.
     
  3. Solowalker macrumors regular

    Joined:
    Feb 13, 2008
    #3
    Could you repost those links? I'm trying to deal with my sister's iPod that may be having the same problem, but those links don't work (they have ... in them when I open them).
     
  4. cmichaelb macrumors 68020

    cmichaelb

    Joined:
    Aug 6, 2008
    Location:
    Kansas
    #4
    http://arstechnica.com/journals/app...n-iphone-app-crashing-how-to-downgrade-itunes

    If this one doesn't work just go to arstechnica webiste, click the apple tab, and find the article titled "More on iPhone app-crashing, how to downgrade iTunes"

    http://discussions.apple.com/thread.jspa?messageID=7917930#7917930

    If this doesn't work go to Apple's dicussions forum and find this thread- Apple.com > Support > Discussions > iPhone Hardware > Original iPhone > iphone 2.0 problems

    He also created a website at:

    http://ja1me.net/iTunes_and_Oops/thanks_for_coming.html

    Hope this helps.

    I've tried this on my iPod Touch and haven't had a problem for 48 hours so far.

    To sum up the process, you wipe iTunes 7.7.1 off of your machine. Delete all the support files (on windows- clean your registry) then reboot. Then install 7.7.0 and then do a full restore on your iPod using 7.7.0 - do not use any backup data -restore as a new iPod. You should have cleaned everything out and have no backup data but just in case....
     
  5. Solowalker macrumors regular

    Joined:
    Feb 13, 2008
    #5
    Actually, she hadn't updated to 2.0.2 yet. I updated it for her and it appears to have fixed the problem. But you never know, it could just be temporary like some of the "fixes" in these updates. So thanks for the repost. It may come in handy in the near future...
     
  6. cmichaelb macrumors 68020

    cmichaelb

    Joined:
    Aug 6, 2008
    Location:
    Kansas
    #6
    Anytime... I'm still problem free after rolling back to iTunes 7.7.0 and THEN updating the iPod firmware. Apparently the problem lies in the 7.7.1 iTunes interaction with 2.0, 2.0.1, and 2.0.2 firmware. :apple:
     
  7. scsimasters macrumors newbie

    Joined:
    Aug 6, 2009
    #7
    Simple way to start your apps after iphone sync

    I have read a lot of the postings about restoring and loading back up files to get your third part apps working again. I had the same problem with my apps not loading and found a post last night that worked like a charm.

    All you have to do is open up the apps store on our phone and download any new app; pick something small like a free flash light and install it. That is it!

    After that all my apps started working again. I guess it is something about the apps store and the phone syncing or complete an installation. Sucks that you have to install something but atleast you can always delete it. Luckly it just takes a minute. Makes me not want to sync my iphone all that often but it beats the head ache of restoring and loading back up files. Simple easy fix. I wish I could take credit for it, so instead I am sharing the love.
     
  8. erphoto macrumors newbie

    Joined:
    Apr 17, 2009
    #8
    Thank You!

    I was in the middle of a book and needed to charge up the ol touch for the first time after installing apps, apps then didn't work, i did what the person above suggested, (installed a new app) and then they started working like new.

    Thanks a lot! now I can go to bed and finish my e-book. xo!
     
  9. carrotyO macrumors newbie

    Joined:
    Jan 16, 2010
    #9
    Solution (worked for me)...

    On your ipod: Check for updates in the application store.
    and update that which needs updating.
    your ipod shall, insha'allah, be happy once again.
     
  10. berniehenrie macrumors newbie

    Joined:
    Jan 28, 2012
    #10
    Applications stop working after sync

    Just had the same problem with a brand new 4s. However when I downloaded one new app, all apps miraculously started working properly, go figure.
     
  11. Cyclonique macrumors newbie

    Joined:
    Aug 5, 2012
    #11
    Is you computer registered?

    I've been having this issue with apps failling to start properly for some time now. It's been bugging me but the simple install an app fudge fix worked. The problem is that sometimes I am out and need to run an app and I am not in a 3G area and then trying to install an app to fix the issue is then not possible.

    I can't say this will fix the issue but have a look at the iTunes application on your computer. (I'm using Win7).

    I noticed that under 'Devices' and in my iPhone and 'Apps' the list of 'Sync Apps' did not correspond the the apps on my phone. (I believe an iPad that has been connected was showing it's apps here)

    So I removed all these apps from the list - for this go to the 'Library' and 'Apps' then right click on all the apps that are misbehaving. (don't worry if you remove a paid for app as it's still on your phone and you can reload it for free anyway).

    Once you have removed all the offending apps then you can add them back into your sync list.

    Go to 'iTunes Store', and for each of the required apps find it (top right hand search box) and reload/install all your apps (you can look at the apps on your phone to do this).

    Now once you have done all this you can go back to your phone under devices and in Apps you should now have all your apps listed in the 'Sync Apps' section. Make sure you click on the automatically sync new apps and sync apps.

    Also as the title of this post says make sure the computer is registered with your iTunes. For this go to the top menu item 'Store' and click on 'Authorise this Computer'

    In my case what was obviously happening to stop my downloaded apps from working was that every time I synchronised my phone with my computer only the sync'ed apps in the list where being re-authorised to work with my phone, all the other apps were not re-authorised. But by added in a new app from the phone it would re-authorise all the apps (seems like a bug on top of a bug to me)

    Anyway I hope thise works for some of you out there.
     

Share This Page