Applications stopped working (after installing update?)

Discussion in 'macOS' started by benderunit, May 26, 2007.

  1. benderunit macrumors newbie

    Joined:
    Jul 5, 2006
    #1
    Hey guys,

    I have pretty serious problem since about two days. I think it happened after installing the last security update (2007-005). I think what happened was that after pressing restart, the computer (white MacBook, about a year old) hung in at the grey screen that appears before it turns of the power.

    After waiting for a couple of minutes and still nothing happened, I forced it off by holding the power button. After turning it on again, I can login, but most applications don't start anymore. Their icon bounces for a few seconds but then just stops, but the application doesn't start, and there's no black triangle next to it.

    "Most applications" includes e.g. Safari, Mail, Adium, Skype, Quicksilver, and iTunes. Fortunately, at least Firefox still works so I can write this post. Also iPhoto, the Address Book and the Calendar don't seem to be affected. Oh yeah, the System Update Program doesn't start anymore, too.

    I already tried repairing the permissions several time but it doesn't help (and actually just says there's nothing to be fixed anyways). Any ideas what could be broken here and how to fix it?

    Thanks in advance!
     
  2. ebouwman macrumors 6502a

    Joined:
    Jan 5, 2007
    Location:
    Canada
    #2
    what it kinda sounded like is that it took a long time to reboot and you got impatient.
    Since when you restart the computer after an update it does some work to the system you may have interrupted this i guess and messed up some system folders.

    I think, not really sure, that that update was a system update so when you force shut down it probably screwed up the system files.

    I just downloaded the update the other day and it did take a really long time to reboot but i just let it do it's thing and it's fine.

    I'm not sure what you can do but you might have to reinstall OSX
     
  3. MacDonaldsd macrumors 65816

    MacDonaldsd

    Joined:
    Sep 8, 2005
    Location:
    London , UK
    #3
    Yeah mine took about 5 minutes to update.

    You could re-downloaded the update from apples website and try re-applying it. Other than that you may have to re-install OS X.
     
  4. Celeron macrumors 6502a

    Joined:
    Mar 11, 2004
    #4
    I agree with what everyone else already said. I did the last security update here on my Mac Pro and the restart took a long time, after which it restarted again, then booted up normally.

    Sounds like you hosed up things by doing th forced power down. I personally would format and reinstall OSX, but that's probably not necessary. I however don't like the possibility of something being corrupted.
     
  5. tranceme macrumors member

    Joined:
    Jan 10, 2006
    Location:
    California, US
    #5
    Can't launch Adobe apps

    I'm having problems after the update as well...I can't start any of my Adobe CS2 apps. Major problem for me.

    I tried to reinstall the apps....no go...can't run installer either.

    I'm suspecting the Security Update or Quicktime Security update caused the problem. This happen last year with the updates as well. You think Apple would test for this considering their Security Update broke Adobe apps last year.

    I just wish Apple would give you the ability to remove an Update...Windoze does...not that Windoze is something to follow. But, in this case, beats Apple when someone is asleep on the QA team.
     
  6. PCMacUser macrumors 68000

    PCMacUser

    Joined:
    Jan 13, 2005
    #6
    So far this sounds like a Windows support thread! Stories of corrupted files, reformatting and reinstallation of the operating system? Surely not on OS X!? :rolleyes:
     

Share This Page