Applications taking too long to launch

Discussion in 'Mac OS X Lion (10.7)' started by danakm, Dec 26, 2011.

  1. danakm macrumors regular

    danakm

    Joined:
    Apr 9, 2006
    Location:
    Wonderland
    #1
    For a couple of weeks now I've noticed my applications bounce for quite some time in the dock before actually launching. Any ideas as to what might be causing this?

    The HDD is only a few months old (no weird clicking sounds or anything) and has plenty of free space and the RAM is plentiful too (8GB), so I have no clue as to what might be happening :confused:
     
  2. Krazy Bill macrumors 68030

    Krazy Bill

    Joined:
    Dec 21, 2011
  3. danakm thread starter macrumors regular

    danakm

    Joined:
    Apr 9, 2006
    Location:
    Wonderland
    #3
    Well, it's taking twice or three times what used to be normal before and I see no particular reason for it to be happening, which is why I'm asking for ideas as what to check/might be wrong :(
     
  4. MWPULSE macrumors 6502a

    MWPULSE

    Joined:
    Dec 27, 2008
    Location:
    London
    #4
    Any particular applications causing issues, is it internal (apple apps??) or externals? (photoshop etc?) Have you checked that they all upto date, via the mac app store, macupdate, or the software developer, could try reinstalling them, try a new account as well? It might be that your account is clogged up a bit, i know mine is, it typically takes about 1min-1.30 for itunes/safari to open.
     

Share This Page