Apps crash under 1.1.1

Discussion in 'Jailbreaks and iOS Hacks' started by jbellny, Oct 20, 2007.

  1. jbellny macrumors newbie

    Joined:
    Oct 15, 2007
    #1
    Ok - successfully installed firmware 1.1.1 and did all the jailbreak/iNDEPENDENCE fun and have AppTapp installed as well.

    Upgraded AppTapp to the 3.0 beta. However, I can't seem to run any other 3rd party app - they launch and then almost immediately go back to the home screen. I tried Five Dive and iBlackJack so far. Both of these worked under 1.02 obviously.

    Anyone see this behavior before? Everything else seemed to go perfectly well. Any ideas would be appreciated.
     
  2. LoneWolf121188 macrumors 6502a

    Joined:
    Jun 7, 2007
    Location:
    Longmont, CO
    #2
    There's a page on the dev team site that has a list of apps known to not work on 1.1.1. Check there first.
     
  3. jbellny thread starter macrumors newbie

    Joined:
    Oct 15, 2007
    #3
    Was the first thing I made of sure of before loading them. They're identified as working but neither does.

    Anyone else with an idea?
     
  4. rush0 macrumors member

    Joined:
    Jul 16, 2007
    #4
    Did you check the permissions on the installed apps on the phone? make sure you have -rwx for them.
     
  5. jbellny thread starter macrumors newbie

    Joined:
    Oct 15, 2007
    #5
    Well, the apps are being installed via AppTapp so setting permissions shouldn't be necessary.

    Now, the weird thing is I did a full re-install and jailbreak. The apps I mentioned above (FiveDice and iBlackJack) worked fine. However, now all of a sudden they again don't work. They begin to load and then return right back to the home screen.

    I'm surprised no one else is seeing this behavior. I did a really basic install on 1.1.1. Oh well...back to 1.02 for me.
     
  6. hexica macrumors newbie

    Joined:
    Oct 29, 2007
    #6
    Having exactly the same problem as jbellny.

    AppTapp installed fine, but all additional software installed using installer.app crashes on startup.

    Shame, don't know why!
     
  7. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #7
    If you have summerboard installed, turn OFF dim wallpaper if you have it on. That is what causes the crashing. I had the same problem over and over again, and this fixed it.

    If thats not your problem, no clue :p
     
  8. harlemink macrumors member

    Joined:
    Oct 10, 2007
    #8
    SO annoying....

    I did the AppSnapp tiff exploit upgrade today. I had successfully downgraded to 1.0.2 and had all my fav apps up and running, but SSHing into my phone (I've been a PC user my whole life and am buying my first mac this week) was just simply above my head.

    AppSnapp worked GREAT, but NOTHING but summerboard works now. No pirates, no iFlickr, no customize, no taskbar notifier, no fivedice, nothing.

    I've uninstalled. I've restarted. I'm bummed.

    Any advice? Any help? I have the dim setting turned off in summerboard so that's not it.
     
  9. bbplayer5 macrumors 68030

    Joined:
    Apr 13, 2007
    #9
    Its possible you had a problem with your 1.1.1 unlock. Id restore and retry it from scratch.
     
  10. harlemink macrumors member

    Joined:
    Oct 10, 2007
    #10
    Success!

    Install BSD Subsystem and all the problems melt away!!

    Thanks tuaw!
     
  11. FunkyJunk macrumors regular

    FunkyJunk

    Joined:
    Oct 17, 2007
    Location:
    Leesburg, VA, USA
    #11
    I tried that and it's not helping. What seems to be the case is that any app installed AFTER you install Summerboard crashes instantly. If you install the app AND THEN install Summerboard, they seem to work.

    edit: I also tried installing BSD Subsystem and that did not fix it.
     
  12. harlemink macrumors member

    Joined:
    Oct 10, 2007
  13. harlemink macrumors member

    Joined:
    Oct 10, 2007
  14. spinstorm macrumors 68000

    Joined:
    Sep 14, 2007
    #14
    I gave up with Installer as it won't work for me - It worked when I did 2 manual windows Jailbreaks but not when I used Independece.

    Why did I do 3 jailbreaks? because I tried THREE times to add international support (ie, so that when I dial a number it has a UK format) to my iPhone

    AND EVERY TIME it ended up as an iPod - and I had to restore back to 1.0.2 and back up to 1.1.1!

    The manual JB method took me 2 days I had so many problems but eventually everything worked INCLUDING Installer... perfectly.

    For some reason Independence did something that makes Installer NOT work properly (it won't refresh or install apps correctly) and so I am without Installer.

    I'm sorta in the middle in so far as how I feel because on the one hand I was going crazy spending days using the manual windows hacks (this was before the automated apps came out) but Installer worked. And now it took me an hour but Installer doesn't work - but everything else is fine. To be fair I can live without installer its just annoying that something always seems to go wrong! lol

    I think something is messed up on my springboard as well as Independence says its restarting the springboard but nothing happens! I had to manually turn the phone on and off to get any 3rd party apps to appear and even then I couldn't put more than 16 on the screen - no scrolling appeared at all!

    So I am guessing Independence didn't patch my springboard properly for more than 16 apps and did something to stop it refreshing!

    As for installer - as it wouldn't refresh sources and seemed to be slow and unresponsive I removed it.

    I put it back a few times and updated it (when that worked although even that didn't work everytime!) and no matter what I tried apps would just crash or not work.

    I think maybe we should be greatful that we can use our iphones at all without AT&T.

    All my standard Apple apps work fine and I did manage to get that "lights out" game working on my phone... but something wierd is going on here.

    I find it really had to believe that we are all having 3rd party app issues with JB'd phones - the process (however it was done) messed up somethings on out phones - no doubt.

    Just ONE thing - sometimes 3rd party apps crash because BSD subsystem IS NOT installed!

    If you did not install it then make sure you do! that MAY fix it - as I said my problem was installer acting wierd so that is nothing to do with the BSD subsystem.
     
  15. Samberino macrumors newbie

    Samberino

    Joined:
    May 27, 2004
    #15
    Same here

    Ok, so I have been going crazy for the past 2 weeks since virginizing my hardware unlocked iphone on 1.0.2 and upgrading to 1.1.1, as I have the exact same problem with apps (even standard apple apps like 'notes' and 'ipod') crashing and returning to the springboard screen. This usually happens 3 to 4 times in a row, afterwhich it sorts itself out and the apps load without returning to the Springboard screen.

    I virginized my 1.0.2 iphone, upgraded to 1.1.1 so that it appeared as factory fresh :) downgraded, jailbreaked, upgraded, activated, yadda, yadaa. I am not sure if I am facing this problem because of Summerboard which I installed, so that I could customize Springboard and apply themes.

    I have got international support enabled, i.e. the 'International' menu option under 'Settings' -> 'General'. To enable this, you are required to edit a file from your iphone on your computers by converting it first to an editable format. Once the changes are made you then have to convert it back to a binary format before copying it back on your iPhone. After re-starting the iPhone you then see the International option under settings. By default it is disabled and I am not sure why. Perhaps iTunes will later (when the iPhone is released internationally officially) enable it, I am not sure.

    I set the 'dim' background wallpaper option to 'off' for now and will see if this makes a difference. I do not want to have to do a restore, though I am scared I will have to. Anyone at all with a concrete solution to this....?
     
  16. Samberino macrumors newbie

    Samberino

    Joined:
    May 27, 2004
    #16
    It works

    Ok, so disabling the 'Dim' wallpaper in SummerBoard solved the issue :)) w00t!
     
  17. Macsterling macrumors regular

    Macsterling

    Joined:
    Sep 24, 2007
    Location:
    Dallas
    #17
    What apps are really worth all this trouble???? I am a recovering hacker for the iphone and found out that messing around with all these apps just wasted too much of my time and made the phone slow at times.. I started thinking to myself what apps are on here that I have to have and I came up with the answer ZERO! I wiped my phone and now I have no problems and can enjoy the phone the way it is. No crashing, no restore, longer battery life and pretty much a flawless working phone.
    Everyone keeps complaining about the phone but if you keep hacking into it what do you expect to happen. Just wait for Apple to release apps for it or febuary when 3rd party will be approved. I think everyone can live without blackjack and 5dice for now :)
     
  18. patrickvanzandt macrumors member

    Joined:
    Sep 19, 2007
    Location:
    U.S.A.
    #18
    I was experiencing the same symptom as jbellny, even after restoring & starting from scratch. After seeing this thread I tried installing BSD Subsystem (through Installer.app 3) as suggested above, followed by a restart. My apps seem to work fine now!
     
  19. Hello77 macrumors newbie

    Joined:
    Nov 13, 2007
    #19
    good to know that Im not the only one...

    Hi,

    I had a 1.0.2 iPhone and bought a 1.1.1 recently (my jealous brother had to take my 1.0.2). My 1.1.1 iPhone started to do funny things like others have mentioned (e.g. returning to the SpringBoard and crashing apps) after installing SummerBoard.

    I deleted the SummerBoard to see if SB is the cause of all these annoying problems - and YES! it is the SB that causing the problems.

    I used my iPhone without SM for a while and the phone works perfect.
    So I've just re-insall the SM - and yes, i'm having the problems again. But I will give it a go for a while and see what it does.

    BTW, I know it sounds not so nice but it's a great comfort to know that I'm not the only one having the 3rd party APP problems.

    Cheers.
    Hello77 :)
     

Share This Page