Apps disconects in background iPhone 4

Discussion in 'iOS 5 and earlier' started by retro9, Mar 24, 2013.

  1. retro9 macrumors newbie

    Joined:
    Mar 24, 2013
    #1
    Hi,
    I have iPhone4 running iOS 5.1.1 It is jailbroken with redsn0w and unlock with ultrasn0w 1.2.8.
    My problem is apps like whatsapp, gmail running in background disconnects. I tried restoring network settings as well but it didn't help. :confused:
    pls help....
     
  2. Thetonyk123 macrumors 68000

    Thetonyk123

    Joined:
    Aug 14, 2011
    Location:
    Earth
    #2
    Is it immediately or it takes awhile? It could just be normal app exiting.
     
  3. retro9 thread starter macrumors newbie

    Joined:
    Mar 24, 2013
    #3
    Thanks for quick reply....

    App stays connected for 10 mins or in background. Is there any way to keep apps (eg. Whatsapp) connected always?
     
  4. Thetonyk123 macrumors 68000

    Thetonyk123

    Joined:
    Aug 14, 2011
    Location:
    Earth
    #4
    I think insomnia could do that, I'd check it out.
     
  5. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #5
    It's normal. Apps are suspended so they will disconnect. However, as long as you have push notifications enabled for these apps you will still get notified when you get a message in whatsapp for example.

    By suspending the apps, they are no longer using cpu cycles and this means better battery life but you will continue getting updates through push notifications and when you reopen the apps they will resume where you left off.
     
  6. retro9 thread starter macrumors newbie

    Joined:
    Mar 24, 2013
    #6
    I already tried insomnia but it didn't work, problem persists. :(


    I have push notification enable in notification center for gmail and whatsapp applications but still these disconnect :(
     
  7. inselstudent macrumors 6502a

    Joined:
    Jul 27, 2012
    #7

    I think it's at least partly due to whatsapp's servers which are simply overloaded by the huge amount of users. Maybe it's a local/temporary issue. At least, everything's okay on my phone. From time to time, though, I get messages late there too.
     
  8. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #8
    The apps disconnect or you are not getting notifications? Like I said, even if they aren't connected, you will get notifications through Push if they were enabled.

    If not, delete the app, reboot the phone, reinstall the app and choose "Yes" when asked if you want to enable push notifications.
     
  9. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #9
    I pretty much never see the enable push notification prompt come up when reinstalling an app that I recently uninstalled. Some have said you have to wait at least a day before reinstalling and seeing that prompt, but even then it doesn't seem like that works.
     
  10. retro9 thread starter macrumors newbie

    Joined:
    Mar 24, 2013
    #10
    Hi,
    I uninstalled application particularly whatsapp and reinstalled same. but problem persists. I wonder if the problem is due to push certification? I read in some threads push certs should be unique to receive those notification. If I try to activate unique push cert via SAM method will it solve my problem of app getting disconnected?

    According to http://jaxov.com/2012/05/activate-iphone-4-3gs-ios-5-1-1-sam-fix-push-notifications-youtube-error/ I have lock iPhone and unlock again with SAM tool. But I have already unlocked it using ultrasn0w so whether it is safe to perform operation?

    Thanks
     

Share This Page