Apps don't start anymore?!!

Discussion in 'macOS' started by jakaj, Oct 22, 2006.

  1. jakaj macrumors member

    Oct 12, 2006

    I have owned a MacBook for 4 days now. It has happened 3 times so far, that at some point, applications in the dock just won't start anymore. Icons will jump up and down and then just stop jumping.

    Open apps will continue to work until they are closed, after which point they are unable to be re-opened.

    I have tried quitting all apps and then relaunching Finder using the Force Quit menu, but even finder wouldn't start anymore.

    I'm using FileVault, can that be the cause of the problems?

  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Disable FileVault. I think it's one of the buggiest things to have come out of Apple and wouldn't rely on it for my data. :eek:

    If that doesn't help, then create a new user account and see whether the problems carry over. Nevertheless, definitely disable FileVault. :)
  3. spicyapple macrumors 68000


    Jul 20, 2006
    Trashing of the app's preferences, and a nice cold reboot usually solves it. You might also want to take this opportunity to boot from your OSX disc and run Disk Utilities and repair your system drive.
  4. Shadow macrumors 68000


    Feb 17, 2006
    Keele, United Kingdom
    I would personally try repairing permissions before anything else. Mainly because its ment to fix this sorta thing.
  5. Badradio macrumors 6502

    Aug 19, 2004
    Agreed. I've seen this same issue (apps won't start) on a Mac where the user wasn't repairing permissions. I assume as it's a new machine you've been installing a lot of apps - if you haven't repaired permissions for a while (or at all) then try this first.
  6. jakaj thread starter macrumors member

    Oct 12, 2006
    mad jew: I won't stop using FileVault. Unless it's really that broken, in which case I'll have to switch to linux to use md-crpyt of something. I need encryption.

    spicyapple: Trashing of what app's preferences? NONE of them started... I will definitely try repairing my drive the next time the problem occurs.

    I have tried repairing the permissions, and indeed it does find three changes, but nothing of relevance. I would very much like to know how some iTunes file can get +x, though...

    I have had another problem today. I have woken up my Macbook from sleep, and the beachball was running for like 10 minutes, until I shut it down holding the power button.

    The system was too unresponsive to even get to Activity Monitor to check which app was responsible, but it wasn't completely frozen.

    Are there any "secret" key combos that would try restarting finder, or the entire graphical server (like ctrl-alt-bksp on xfree86) ?
  7. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    COMMAND-OPTION-ESCAPE should give you a Force Quit dialogue box similar in concept to the CONTROL-ALT-DELETE option in Windows. It doesn't always work if the system is frozen but it's worth a try. It should tell you which app is frozen too.

    Having said that, I really recommend you stop using File Vault. There's no point to encryption if it messes with your data to the point that even you can't get to it. I don't personally need heavy security so I don't know of any good third party alternatives, but maybe look into using an encrypted disk image (created in Disk Utility) in the meantime. It should restrict your problems to just one area of the machine. :)
  8. rasjunk macrumors member

    Jun 25, 2005
    The same thing has just happened to me. My laptop had been on for a couple of days (as it usually is). I came home from work and tried to open inDesign. The icon bounced a few times and then stopped - remained on the dock until I right-clicked and chose force quit. Word won't open either. Firefox,mail,textedit and others work fine.

    When I boot or restart the spotlight icon appears first with the background. 5-10 minutes later everything else loads.

    I repaired permissions (everything was fine) and then I clicked Verify Disk. It reported an error. I don't have my installation cd with me. I booted in safe mode and ran Verify Disk again and it reported no problems (now it reports no problems in regular mode too).

    My FW800 drive seemed to be acting up too. I backed up my laptops hard drive to the external drive and accidentally deleted everything that was previously on that drive (300gigs of files). I'm using data rescue to get some of that back.

    I cleared the pram or whatever it was but that didn't seem to help.

    Sorry for the long/pointless post

    -> G4 Powerbook 1.67
  9. btcomm macrumors regular

    Oct 18, 2006
    I could be wrong, but it almost sounds like there could be some sort of Hardware issue, if you still have the option, you might want to call Apple to see if they will agree, if so you will have to send the laptop in for repair.
  10. jakaj thread starter macrumors member

    Oct 12, 2006
    Actually, I'd rather see I lost my data than see it come into bad hands should my laptop get stolen or something... I know it sounds weird, but if, for example, sources of the applications the company I work for develops got stolen, it could be a problem.

    I was thinking about creating a fixed size encrypted image (because I hear they're more reliable than sparse images), but I guess I would then have to make it automatically mount as my home dir upon login, prior to opening finder etc. I have no idea how to make that happen in OS X.

    Using it just as a folder inside my home dir is not an option, since I want all the (potentially sensitive) data, like application's preferences, to be encrypted.

Share This Page