Apps freezing: can't force quit

Discussion in 'macOS' started by jimtron, Jul 27, 2008.

  1. jimtron macrumors member

    Joined:
    Jul 27, 2008
    #1
    I have a mac pro with 10.5.4 (Intel 2.66 Dual-Core -- 5GB ram) installed. Things have been running smoothly for a long time, but recently I've had a few kernel panics, which seem to have gone away, but now it's very common for applications to freeze, and I can't unfreeze them by force-quitting--I have to power the G5 down by holding the power button.

    I've tried zapping PRAM, running Diskwarrior, repairing disk permissions, and running Onyx (cleaning caches, running monthly maintenance).

    Any other ideas of things I can try?

    Oh yeah, I've had all 4 internal drive bays filled, and fairly recently swapped one--a 1TB drive. That was around the time problems started, so I'm wondering if that could have something to do with it. I realized after installing that I left a jumper in, which limited the data rate, but I've since removed that. I would appreciate any advice. Thanks.

    ETA: Sorry if this belongs in the Mac Pro forum instead of OS X. Also:


    I saved the log from one of my kernel panics:
    Wed Jul 23 17:54:14 2008
    panic(cpu 3 caller 0x001A8CD4): Kernel trap at 0x00e647b7, type 14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x00000004, CR3: 0x01232000, CR4: 0x00000660
    EAX: 0x00000000, EBX: 0x089ca400, ECX: 0x089ca504, EDX: 0x089cc318
    CR2: 0x00000004, EBP: 0x66deff58, ESI: 0x089ca458, EDI: 0x00e64980
    EFL: 0x00010293, EIP: 0x00e647b7, CS: 0x00000008, DS: 0x08740010
    Error code: 0x00000002

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x66defd68 : 0x12b0fa (0x4592a4 0x66defd9c 0x133243 0x0)
    0x66defdb8 : 0x1a8cd4 (0x46280c 0xe647b7 0xe 0x461fbc)
    0x66defe98 : 0x19ede5 (0x66defeb0 0x0 0x66deff58 0xe647b7)
    0x66defea8 : 0xe647b7 (0xe 0x48 0x66de0010 0x410010)
    0x66deff58 : 0xe649b9 (0x89864a0 0x27a317ea 0x66deff78 0x1a236f)
    0x66deff78 : 0x13eb1d (0x89ca400 0x0 0x0 0x0)
    0x66deffc8 : 0x19ebdc (0x0 0x0 0x1a20b5 0x125b83c8)
    Backtrace terminated-invalid frame pointer 0
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.iokit.IOAHCIBlockStorage(1.1.0)@0xe62000->0xe71fff
    dependency: com.apple.iokit.IOAHCIFamily(1.0.4)@0xd69000
    dependency: com.apple.iokit.IOStorageFamily(1.5.2)@0xae2000

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9E17

    Kernel version:
    Darwin Kernel Version 9.4.0: Mon Jun 9 19:30:53 PDT 2008; root:xnu-1228.5.20~1/RELEASE_I386
    System model name: MacPro1,1 (Mac-F4208DC8)
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    After looking through your kernel panic log, I strongly suspect that the cause is the drive you replaced. It makes mention of IO-related kernel modules, and nothing else. If this particular kernel panic occurred early in the boot process, that would entirely explain why so few modules were loaded.
     
  3. jimtron thread starter macrumors member

    Joined:
    Jul 27, 2008
    #3
    Thanks for the response. Any ideas on how I can troubleshoot this? Also, now that you mention I/O problems, I was having card read errors with at least 3 different CD card readers (USB and FW) and several different CF cards.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    If the destination for the card read was on the offending drive - that would explain the errors. The cards are fine - it's the disk that's the problem.

    One way to troubleshoot this is to look at your Console logs for disk-related things. This can help you pinpoint exactly where the problem lies, if you suspect I/O as the cause. I can help interpret logs, if need be.
     
  5. jimtron thread starter macrumors member

    Joined:
    Jul 27, 2008
    #5
    Yeah, I'm pretty sure the cards are fine because the problem has happened with 4 different ones, including brand new cards. But I installed the new hard drive after the CF card problems. I'll start watching the Console logs--I haven't been doing that. Maybe I'll post them here.

    Another question: where's a good place to learn how to interpret the Console logs?

    Thanks!
     
  6. jimtron thread starter macrumors member

    Joined:
    Jul 27, 2008
    #6
    I'm still having trouble with apps freezing, and I can't force quit them. I end up having to power down the computer with the power button. I can post my console logs, but I'm not sure which ones to post--system.log? Others?

    If anyone has any troubleshooting ideas, I'd love to hear them. I've tried rebuilding permissions, running Diskwarrior, Onyx, fsck -y, and zapping PRAM.
     
  7. shauntrillo macrumors newbie

    Joined:
    Dec 4, 2008
    #7
    I have the exact same problem with my iMac running 10.5.5. Help.
     
  8. jimtron thread starter macrumors member

    Joined:
    Jul 27, 2008
    #8
    This was months ago, so I may be forgetting something, but I'm pretty sure what solved this was doing a clean install--wiping the drive, and doing a fresh install without keeping any old libraries or anything.
     

Share This Page