Apps from App Store not working after jailbreak. How can this be fixed?

Discussion in 'Jailbreaks and iOS Hacks' started by jonny1480, Nov 5, 2009.

  1. jonny1480 macrumors newbie

    Joined:
    Jul 14, 2008
    Location:
    Seattle, WA
    #1
    Hi guys,

    I recently used the newest pwnage tool to jailbreak my iPhone 3G. I am on AT&T so I didn't need to unlock it. After I completed the jailbreak I downloaded a bunch of apps from Cydia and then tried to get Pandora and a couple of other apps from the App Store. They downloaded just fine, but when you try to open them they close within seconds.

    I searched this forum and the internet for a fix for this and the only thing I found was to "deauthorize" my computer from iTunes, Sync the iPhone, "authorize" from iTunes and sync the iPhone again. It worked for some people, but not me. Any ideas?

    Also, for some reason my iPhone screen stays lit after I am finished using it and I have to manually hit the power button to turn off the screen. Any ideas on that? Is it because I am running Backgrounder?

    Thanks for your help!
     
  2. FastangV6 macrumors regular

    FastangV6

    Joined:
    Oct 1, 2007
    #2
    This is definitely not normal behavior. I would suggest a restore, re-jb, and setup as new phone. This has always taken care of all of my issues.
     
  3. k.i.t.t.o. macrumors newbie

    Joined:
    Mar 21, 2008
    #3
    Something similar happened to me a while back. I deleted every app store apps from the phone, then synced them back using iTunes and they worked again.
     
  4. jonny1480 thread starter macrumors newbie

    Joined:
    Jul 14, 2008
    Location:
    Seattle, WA
    #4
    Trying that now...Wish me luck!

    I tried to delete all the apps and add them through iTunes a couple of times without success. :(
     

Share This Page