Apps have stopped updating - It's been two days now

Discussion in 'Apple Watch' started by Dukecitydawg, Jul 13, 2015.

  1. Dukecitydawg, Jul 13, 2015
    Last edited: Jul 13, 2015

    Dukecitydawg macrumors newbie

    Joined:
    May 22, 2015
    #1
    My apps have stopped refreshing (Fantastical, Stocks, HiDef Radar, Altitude, Calendar). When I touch them, they just spin forever. Show up as "blank" on my watch face. Tried resetting phone and Watch with no luck. Any ideas?
     
  2. BlueMoon63 macrumors 68000

    Joined:
    Mar 30, 2015
    #2
    Have you tried turning them off on the watch and then putting back on? That will uninstall the apps and then reinstall the apps. Worth a shot?

    Your issue seems very odd since you tried the standard and the next step is unpair and re-pair
     
  3. mchoffa macrumors 6502a

    Joined:
    Jul 12, 2008
    Location:
    Asheville, NC
    #3
    This happened to my wife while on vacation. For three days she wasn't getting weather or mapmyrun on the watch to work. Not sure WHY exactly, but it fixed itself after we got out of the hotel we were in and back to a place with good network connections. Hers went a little further, in that she wasn't receiving some iMessages on her phone either, and the last day her battery was draining at an alarming rate (iPhone 6 lost 80% of battery in 3 hours in her purse, watch lost 40-50%). At the hotel, I'd tried turning wifi on off, resetting bluetooth, turning phone and watch to airplane mode and back, rebooting both, all multiple times. I was thinking I'd have to unpair and reset the watch when we got home, but once we got down the road everything started updating again. During this time, my phone and watch were working perfectly on the same networks though, so I really have no clue what was up. That was 2 weeks ago and everything's still good on hers.
     
  4. Dukecitydawg thread starter macrumors newbie

    Joined:
    May 22, 2015
    #4
    I am on the same networks (home and work) that I always am on. Strange. Going on day 3 with no updates. Messages are about 12 hours late. Just got a Message on my Watch that showed up on my iPhone 12 hours ago!

     
  5. Kavier macrumors 6502a

    Kavier

    Joined:
    Feb 1, 2010
    Location:
    Raleigh, NC
    #5
    Mine does this occasionally. If I go to the app list on my phone, the toggle saying the app is on my phone will show that the app isn't installed even if it is. If I slide the toggle to green, the app "installs," and I am able to use it again. Not sure if this will work for you, but it's worked for me so far.
     

Share This Page