Apps not letting me upgrade?

Discussion in 'iPhone' started by Anthony T, Sep 12, 2008.

  1. Anthony T macrumors 6502a

    Joined:
    Jul 10, 2008
    #1
    I got a replacement iPhone the other day, and I had this problem with all of my apps that needed updates at first, but now it's just 2 of them that are giving me this problem.

    It says that I need to update 2 of my apps (BreakClassic and Ambiance). However, when I try to do so, it says I cannot upgrade them unless I have the original version and tells me I have to buy them again.

    When I called Apple, the woman told me to just hit "buy" and I wouldn't be charged again, and if I were, they would be happy to refund the cost. So I hit buy, and then it told me that I couldn't upgrade because "the apps are currently being modified. Please try again later."

    Anyone else have this issue before?
     
  2. StingerT125 macrumors 6502a

    StingerT125

    Joined:
    Jun 3, 2008
    Location:
    Dutchess County New York
    #2
    I have had that message before. I think the developer was making some changes. I tried again teh next day and it was able to process then.
     

Share This Page