Apps not opening after jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by JasonReid, Dec 1, 2009.

  1. JasonReid macrumors member

    Joined:
    Jan 21, 2006
    #1
    I just jailbroke my iPhone 3GS for the first time using Blackra1n. Not none of the apps I have downloaded work, they open then immediately crash. Only the core iPhone apps work. Any ideas?
     
  2. radioBirdman macrumors newbie

    Joined:
    Nov 25, 2009
    #2

    What are the apps you have downloaded and where have you downloaded them from?

    A bit more info might help?
     
  3. JasonReid thread starter macrumors member

    Joined:
    Jan 21, 2006
    #3
    All of the apps I had on my phone before the jailbreak, App Store apps.
     
  4. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #4
    Rejailbreak.
    Set up as new phone
    Install apps
    Reboot.
     
  5. JUSTQUAN macrumors member

    Joined:
    Jul 3, 2009
    #5
    what he said, but make sure you get a list of your apps and your jailbroken apps(cydia or rock). what i did was snapshot my screen showing a list of my apps using rock or icy. yes it took a min but worth it.
     
  6. JasonReid thread starter macrumors member

    Joined:
    Jan 21, 2006
    #6
    OK, so I restored it to factory settings, then restored from backup so it is no longer jailbroke. It still wont open App Store Apps. Is there anyway to do this without having to completely start without anything on it. I don't want to loose any text messages and all that stuff.
     
  7. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #7
    Delete the apps in iTunes, send to the recycle bin.

    Sync the phone, don't accept the transfer of apps back to iTunes.

    Redownload the apps from App Store, either directly or via iTunes, either will work.
     
  8. ckong macrumors regular

    Joined:
    Nov 12, 2009
    #8
    Jason, try to download just one app from the iTunes AppStore. Any free one will do. I've read previous posts on Apple own forums that this may fix the issue. It's something to do with the way the apps are protected, and loading a new one authorizes the iPhone again.

    It's been a while since I read this, but you can search here for more clues:

    http://discussions.apple.com/category.jspa?categoryID=201
     
  9. JasonReid thread starter macrumors member

    Joined:
    Jan 21, 2006
    #9
    I tried this and it didn't work. the new app, as well as the old ones still don't work.

    Moi un Mouton, I'll try that and see if it works
     
  10. TeamDNA macrumors 6502

    Joined:
    Sep 7, 2009
    #10
    Restoring from a backup causes problems. Set up as new phone.
     
  11. JasonReid thread starter macrumors member

    Joined:
    Jan 21, 2006
    #11
    Is there any way to do this and restore all my text messages?
     
  12. JasonReid thread starter macrumors member

    Joined:
    Jan 21, 2006
    #12
    Nevermind, I got it working. I deleted all apps in iTunes, then re-downloaded them on the phone and it's working now. Thanks for the help everyone.
     
  13. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
  14. Deucerok macrumors newbie

    Joined:
    Dec 11, 2008
    #14
    My personal glitch

    I'm seeing the same issue right now. I cannot get my apps to work. I've tried rebooted the device, re-broke the device, I've deleted all apps and reinstalled.

    PLEASE HELP! I need to use Skype to make calls to my FAMs out of the States

    -Deuce.Rok
     
  15. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #15
    Did you follow the steps in post #7 above?
     
  16. Deucerok macrumors newbie

    Joined:
    Dec 11, 2008
    #16
    To no avail

    Yes, I tried 2 methods:

    1. Deleted apps completely (Sent to trash and erased completely)
    2. Redownloaded on iPhone
    3. No luck

    1. Deleted apps completely (Sent to trash and erased completely)
    2. Redownloaded on Comp
    3. Sync'ed with Phone (after deleting the last attempt)
    4. Rebooted Phone, No luck

    -Deuce.Rok
     
  17. cscturulo macrumors newbie

    cscturulo

    Joined:
    Jul 18, 2002
    #17
    That's what I was going to suggest, glad you got it working.
     
  18. steve knight Suspended

    steve knight

    Joined:
    Jan 28, 2009
    #18
    I get this once in awhile when my phone crashes or I turn it off. sometimes deleting a app will get them working or just syncing with my computer will get them going. no clue why.
     

Share This Page